Skip to content

← Public intelligence

npm package

@ckeditor/ckeditor5-markdown-gfm

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

3 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 5.8npmAmendedPublished

    CKEditor5 cross-site scripting vulnerability caused by the editor instance destroying process

    CVE-2022-31175 · GHSA-42wq-rch8-6f6j

    Affected
    • npm @ckeditor/ckeditor5-markdown-gfm < 35.0.1
    Fixed in
    35.0.1· Vendor fix available
    Issue
    Affected packages @ckeditor/ckeditor5-markdown-gfm @ckeditor/ckeditor5-html-support @ckeditor/ckeditor5-html-embed Impact A cross-site scripting vulnerability has been discovered affecting three optional CKEditor 5's packages. The vulnerability allowed to trigger a JavaScript code after fulfilling special conditions: a) Using one of the affected packages. In case of ckeditor5-html-support and ckeditor5-html-embed, additionally, it was required to use a configuration that allows unsafe markup inside the editor, b) Initializing the editor on an element and using an element other than <textarea as a base, c) Destroying the editor instance. The root cause of the issue was a mechanism responsible for updating the source element with the markup coming from the CKEditor 5 data pipeline after destroying the editor. This vulnerability might affect a small percent of integrators that depend on dynamic editor initialization/destroy and use Markdown, General HTML Support or HTML embed features.…

    Recommended action: Upgrade to 35.0.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. Medium, CVSS 6.5npmAmendedPublished

    Regular expression Denial of Service in multiple packages

    CVE-2021-21391 · GHSA-3rh3-wfr4-76mj

    Affected
    • npm @ckeditor/ckeditor5-markdown-gfm <= 26.0.0
    Fixed in
    27.0.0· Vendor fix available
    Issue
    Impact A regular expression denial of service (ReDoS) vulnerability has been discovered in multiple CKEditor 5 packages. The vulnerability allowed to abuse particular regular expressions, which could cause a significant performance drop resulting in a browser tab freeze. It affects all users using the CKEditor 5 packages listed above at version <= 26.0.0. Patches The problem has been recognized and patched. The fix will be available in version 27.0.0. For more information Email us at security@cksource.com if you have any questions or comments about this advisory. Acknowledgements The CKEditor 5 team would like to thank Yeting Li for recognizing and reporting these vulnerabilities.

    Recommended action: Upgrade to 27.0.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  3. Medium, CVSS 6.5npmAmendedPublished

    CKEditor 5 Markdown plugin Regular expression Denial of Service

    CVE-2021-21254 · GHSA-hgmg-hhc8-g5wr

    Affected
    • npm @ckeditor/ckeditor5-markdown-gfm <= 24.0.0
    Fixed in
    25.0.0· Vendor fix available
    Issue
    Impact A regular expression denial of service (ReDoS) vulnerability has been discovered in the CKEditor 5 Markdown plugin code. The vulnerability allowed to abuse a link recognition regular expression, which could cause a significant performance drop resulting in a browser tab freeze. It affects all users using the CKEditor 5 Markdown plugin at version <= 24.0.0. Patches The problem has been recognized and patched. The fix will be available in version 25.0.0. Workarounds The user can work around the issue by: - Upgrading CKEditor 5 to version 25.0.0. - Disabling the Markdown plugin. More information If you have any questions or comments about this advisory: Email us at security@cksource.com Acknowledgements The CKEditor 5 team would like to thank Erik Krogh Kristensen from the GitHub team for recognizing this vulnerability and Alvaro Muñoz from GitHub for reporting it.

    Recommended action: Upgrade to 25.0.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →