CKEditor 5 Markdown plugin Regular expression Denial of Service
CVE-2021-21254GHSA-hgmg-hhc8-g5wr
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@ckeditor/ckeditor5-markdown-gfm 25.0.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @ckeditor/ckeditor5-markdown-gfm
- Affected
- <= 24.0.0
- Fixed in
- 25.0.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-hgmg-hhc8-g5wr lists affected ranges: npm @ckeditor/ckeditor5-markdown-gfm >=0 <25.0.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-hgmg-hhc8-g5wr lists affected ranges: npm @ckeditor/ckeditor5-markdown-gfm >=0 <=24.0.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2021-21254: 1.81% estimated exploitation activity in the next 30 days; percentile 78.69 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact A regular expression denial of service (ReDoS) vulnerability has been discovered in the CKEditor 5 Markdown plugin code. The vulnerability allowed to abuse a link recognition regular expression, which could cause a significant performance drop resulting in a browser tab freeze. It affects all users using the CKEditor 5 Markdown plugin at version <= 24.0.0. Patches The problem has been recognized and patched. The fix will be available in version 25.0.0. Workarounds The user can work around the issue by: - Upgrading CKEditor 5 to version 25.0.0. - Disabling the Markdown plugin. More information If you have any questions or comments about this advisory: Email us at security@cksource.com Acknowledgements The CKEditor 5 team would like to thank Erik Krogh Kristensen from the GitHub team for recognizing this vulnerability and Alvaro Muñoz from GitHub for reporting it.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-hgmg-hhc8-g5wr
- Revision 1 · created ·
Published from osv record GHSA-hgmg-hhc8-g5wr
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-21254 Advisory: CKEditor 5 Markdown plugin Regular expression Denial of Service IDs: CVE-2021-21254, GHSA-hgmg-hhc8-g5wr Record: https://patchnext.com/advisories/cve-2021-21254 (revision 2, source checked 26 Oct 2026, 12:17 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @ckeditor/ckeditor5-markdown-gfm 25.0.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @ckeditor/ckeditor5-markdown-gfm: affected <= 24.0.0; fixed in 25.0.0 ## Suggested inspection (read-only) - `npm ls @ckeditor/ckeditor5-markdown-gfm --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @ckeditor/ckeditor5-markdown-gfm. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-hgmg-hhc8-g5wr (OSV record GHSA-hgmg-hhc8-g5wr lists affected ranges: npm @ckeditor/ckeditor5-markdown-gfm >=0 <25.0.0 (fixed)) - Verified: https://github.com/advisories/GHSA-hgmg-hhc8-g5wr (GitHub-reviewed advisory GHSA-hgmg-hhc8-g5wr lists affected ranges: npm @ckeditor/ckeditor5-markdown-gfm >=0 <=24.0.0) Commands are suggestions: review each one before running it.
Loading voting…