Skip to content

← Actionable
Medium, CVSS 6.4amended

CKEditor 5 has Cross-site Scripting (XSS) in the HTML Support package

CVE-2026-28343GHSA-jrqm-vmqc-gm93

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (ckeditor5 47.6.0; @ckeditor/ckeditor5-html-support 47.6.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.4 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
EPSS
  • CVE-2026-28343: 0.32% estimated exploitation activity in the next 30 days; percentile 24.91 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact A Cross-Site Scripting (XSS) vulnerability has been discovered in the General HTML Support feature. This vulnerability could be triggered by inserting specially crafted markup, leading to unauthorized JavaScript code execution, if the editor instance used an unsafe General HTML Support configuration. This vulnerability affects only installations where the editor configuration meets the following criteria: General HTML Support is enabled, General HTML Support configuration allows inserting unsafe markup (see Security section to learn more). Patches The problem has been recognized and patched. The fix will be available in version 47.6.0 (and above). Workarounds CKEditor 5 recommends configuring General HTML Support securely to ensure that unsafe content is not accepted. Please refer to the Security section for detailed guidance. Credits CKEditor 5 would like to thank: - Emilio Kevin - Jeongwoo Lee, Younsoung Kim, Minseok Kim and Jinyeong Kim from ENKI Whitehat for responsibly…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-jrqm-vmqc-gm93

  2. Revision 1 · created ·

    Published from osv record GHSA-jrqm-vmqc-gm93

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-28343

Advisory: CKEditor 5 has Cross-site Scripting (XSS) in the HTML Support package
IDs: CVE-2026-28343, GHSA-jrqm-vmqc-gm93
Record: https://patchnext.com/advisories/cve-2026-28343 (revision 2, source checked 26 Oct 2026, 12:46 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: ckeditor5 47.6.0; @ckeditor/ckeditor5-html-support 47.6.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm ckeditor5: affected >= 29.0.0, < 47.6.0; fixed in 47.6.0
- npm @ckeditor/ckeditor5-html-support: affected >= 29.0.0, < 47.6.0; fixed in 47.6.0

## Suggested inspection (read-only)
- `npm ls ckeditor5 --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls @ckeditor/ckeditor5-html-support --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on ckeditor5, @ckeditor/ckeditor5-html-support.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-jrqm-vmqc-gm93 (OSV record GHSA-jrqm-vmqc-gm93 lists affected ranges: npm @ckeditor/ckeditor5-html-support >=29.0.0 =29.0.0 <47.6.0 (fixed))
- Verified: https://github.com/advisories/GHSA-jrqm-vmqc-gm93 (GitHub-reviewed advisory GHSA-jrqm-vmqc-gm93 lists affected ranges: npm @ckeditor/ckeditor5-html-support >=29.0.0 =29.0.0 <47.6.0)

Commands are suggestions: review each one before running it.

Loading voting…