Skip to content

← Public intelligence

PyPI package

streampipes

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

4 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 6.5PyPIAmendedPublished

    Apache StreamPipes has improper privilege management in a REST interface

    CVE-2024-24778 · GHSA-vm7w-2724-5m23

    Affected
    • PyPI streampipes < 0.97.0
    Fixed in
    0.97.0· Vendor fix available
    Issue
    Improper privilege management in a REST interface allowed registered users to access unauthorized resources if the resource ID was known. This issue affects Apache StreamPipes: through 0.95.1. Users are recommended to upgrade to version 0.97.0 which fixes the issue.

    Recommended action: Upgrade to 0.97.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. High, CVSS 8.7PyPIAmendedPublished

    Apache StreamPipes has potential remote code execution (RCE) via file upload

    CVE-2024-31411 · GHSA-6523-jf4r-c962

    Affected
    • PyPI streampipes < 0.95.0
    Fixed in
    0.95.0· Vendor fix available
    Issue
    Unrestricted Upload of File with dangerous type vulnerability in Apache StreamPipes. Such a dangerous type might be an executable file that may lead to a remote code execution (RCE). The unrestricted upload is only possible for authenticated and authorized users. This issue affects Apache StreamPipes: through 0.93.0. Users are recommended to upgrade to version 0.95.0, which fixes the issue.

    Recommended action: Upgrade to 0.95.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  3. Medium, CVSS 6.9PyPIAmendedPublished

    Apache StreamPipes potentially allows creation of multiple identical accounts

    CVE-2024-30471 · GHSA-2qph-v9p2-q2gv

    Affected
    • PyPI streampipes < 0.95.0
    Fixed in
    0.95.0· Vendor fix available
    Issue
    Time-of-check Time-of-use (TOCTOU) Race Condition vulnerability in Apache StreamPipes in user self-registration. This allows an attacker to potentially request the creation of multiple accounts with the same email address until the email address is registered, creating many identical users and corrupting StreamPipe's user management. This issue affects Apache StreamPipes: through 0.93.0. Users are recommended to upgrade to version 0.95.0, which fixes the issue.

    Recommended action: Upgrade to 0.95.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  4. Medium, CVSS 5.3PyPIAmendedPublished

    Apache StreamPipes has possibility of SSRF in pipeline element installation process

    CVE-2024-31979 · GHSA-9gr7-gh74-qg9x

    Affected
    • PyPI streampipes < 0.95.0
    Fixed in
    0.95.0· Vendor fix available
    Issue
    Server-Side Request Forgery (SSRF) vulnerability in Apache StreamPipes during installation process of pipeline elements. Previously, StreamPipes allowed users to configure custom endpoints from which to install additional pipeline elements. These endpoints were not properly validated, allowing an attacker to get StreamPipes to send an HTTP GET request to an arbitrary address. This issue affects Apache StreamPipes: through 0.93.0. Users are recommended to upgrade to version 0.95.0, which fixes the issue.

    Recommended action: Upgrade to 0.95.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →