Apache StreamPipes has improper privilege management in a REST interface
CVE-2024-24778GHSA-vm7w-2724-5m23
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (streampipes 0.97.0; org.apache.streampipes:streampipes-parent 0.97.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI streampipes
- Affected
- < 0.97.0
- Fixed in
- 0.97.0
Maven org.apache.streampipes:streampipes-parent
- Affected
- < 0.97.0
- Fixed in
- 0.97.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-vm7w-2724-5m23 lists affected ranges: Maven org.apache.streampipes:streampipes-parent >=0 =0 <0.97.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-vm7w-2724-5m23 lists affected ranges: Maven org.apache.streampipes:streampipes-parent >=0 =0 <0.97.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
- EPSS
- CVE-2024-24778: 0.69% estimated exploitation activity in the next 30 days; percentile 52.91 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Improper privilege management in a REST interface allowed registered users to access unauthorized resources if the resource ID was known. This issue affects Apache StreamPipes: through 0.95.1. Users are recommended to upgrade to version 0.97.0 which fixes the issue.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-vm7w-2724-5m23
- Revision 1 · created ·
Published from osv record GHSA-vm7w-2724-5m23
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-24778 Advisory: Apache StreamPipes has improper privilege management in a REST interface IDs: CVE-2024-24778, GHSA-vm7w-2724-5m23 Record: https://patchnext.com/advisories/cve-2024-24778 (revision 2, source checked 26 Oct 2026, 13:32 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: streampipes 0.97.0; org.apache.streampipes:streampipes-parent 0.97.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI streampipes: affected < 0.97.0; fixed in 0.97.0 - Maven org.apache.streampipes:streampipes-parent: affected < 0.97.0; fixed in 0.97.0 ## Suggested inspection (read-only) - `python -m pip show streampipes`: prints the installed version. Run with the environment that serves production active. - Maven org.apache.streampipes:streampipes-parent: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on streampipes, org.apache.streampipes:streampipes-parent. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-vm7w-2724-5m23 (OSV record GHSA-vm7w-2724-5m23 lists affected ranges: Maven org.apache.streampipes:streampipes-parent >=0 =0 <0.97.0 (fixed)) - Verified: https://github.com/advisories/GHSA-vm7w-2724-5m23 (GitHub-reviewed advisory GHSA-vm7w-2724-5m23 lists affected ranges: Maven org.apache.streampipes:streampipes-parent >=0 =0 <0.97.0) Commands are suggestions: review each one before running it.
Loading voting…