Skip to content

← Actionable
High, CVSS 8.7amended

Apache StreamPipes has potential remote code execution (RCE) via file upload

CVE-2024-31411GHSA-6523-jf4r-c962

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (streampipes 0.95.0; org.apache.streampipes:streampipes-parent 0.95.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2024-31411: 1.11% estimated exploitation activity in the next 30 days; percentile 65.84 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Unrestricted Upload of File with dangerous type vulnerability in Apache StreamPipes. Such a dangerous type might be an executable file that may lead to a remote code execution (RCE). The unrestricted upload is only possible for authenticated and authorized users. This issue affects Apache StreamPipes: through 0.93.0. Users are recommended to upgrade to version 0.95.0, which fixes the issue.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-6523-jf4r-c962

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-6523-jf4r-c962

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-31411

Advisory: Apache StreamPipes has potential remote code execution (RCE) via file upload
IDs: CVE-2024-31411, GHSA-6523-jf4r-c962
Record: https://patchnext.com/advisories/cve-2024-31411 (revision 3, source checked 26 Oct 2026, 13:30 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: streampipes 0.95.0; org.apache.streampipes:streampipes-parent 0.95.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI streampipes: affected < 0.95.0; fixed in 0.95.0
- Maven org.apache.streampipes:streampipes-parent: affected < 0.95.0; fixed in 0.95.0

## Suggested inspection (read-only)
- `python -m pip show streampipes`: prints the installed version. Run with the environment that serves production active.
- Maven org.apache.streampipes:streampipes-parent: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on streampipes, org.apache.streampipes:streampipes-parent.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-6523-jf4r-c962 (OSV record GHSA-6523-jf4r-c962 lists affected ranges: Maven org.apache.streampipes:streampipes-parent >=0 =0 <0.95.0 (fixed))
- Verified: https://github.com/advisories/GHSA-6523-jf4r-c962 (GitHub-reviewed advisory GHSA-6523-jf4r-c962 lists affected ranges: Maven org.apache.streampipes:streampipes-parent >=0 =0 <0.95.0)

Commands are suggestions: review each one before running it.

Loading voting…