Apache StreamPipes has possibility of SSRF in pipeline element installation process
CVE-2024-31979GHSA-9gr7-gh74-qg9x
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (streampipes 0.95.0; org.apache.streampipes:streampipes-parent 0.95.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI streampipes
- Affected
- < 0.95.0
- Fixed in
- 0.95.0
Maven org.apache.streampipes:streampipes-parent
- Affected
- < 0.95.0
- Fixed in
- 0.95.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-9gr7-gh74-qg9x lists affected ranges: Maven org.apache.streampipes:streampipes-parent >=0 =0 <0.95.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-9gr7-gh74-qg9x lists affected ranges: Maven org.apache.streampipes:streampipes-parent >=0 =0 <0.95.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 5.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N · score source
- EPSS
- CVE-2024-31979: 0.74% estimated exploitation activity in the next 30 days; percentile 54.58 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Server-Side Request Forgery (SSRF) vulnerability in Apache StreamPipes during installation process of pipeline elements. Previously, StreamPipes allowed users to configure custom endpoints from which to install additional pipeline elements. These endpoints were not properly validated, allowing an attacker to get StreamPipes to send an HTTP GET request to an arbitrary address. This issue affects Apache StreamPipes: through 0.93.0. Users are recommended to upgrade to version 0.95.0, which fixes the issue.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-9gr7-gh74-qg9x
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-9gr7-gh74-qg9x
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-31979 Advisory: Apache StreamPipes has possibility of SSRF in pipeline element installation process IDs: CVE-2024-31979, GHSA-9gr7-gh74-qg9x Record: https://patchnext.com/advisories/cve-2024-31979 (revision 3, source checked 26 Oct 2026, 13:30 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: streampipes 0.95.0; org.apache.streampipes:streampipes-parent 0.95.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI streampipes: affected < 0.95.0; fixed in 0.95.0 - Maven org.apache.streampipes:streampipes-parent: affected < 0.95.0; fixed in 0.95.0 ## Suggested inspection (read-only) - `python -m pip show streampipes`: prints the installed version. Run with the environment that serves production active. - Maven org.apache.streampipes:streampipes-parent: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on streampipes, org.apache.streampipes:streampipes-parent. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-9gr7-gh74-qg9x (OSV record GHSA-9gr7-gh74-qg9x lists affected ranges: Maven org.apache.streampipes:streampipes-parent >=0 =0 <0.95.0 (fixed)) - Verified: https://github.com/advisories/GHSA-9gr7-gh74-qg9x (GitHub-reviewed advisory GHSA-9gr7-gh74-qg9x lists affected ranges: Maven org.apache.streampipes:streampipes-parent >=0 =0 <0.95.0) Commands are suggestions: review each one before running it.
Loading voting…