Skip to content

← Public intelligence

PyPI package

langchain-community

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

6 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 7.5PyPIAmendedPublished

    Langchain Community Vulnerable to XML External Entity (XXE) Attacks

    CVE-2025-6984 · GHSA-pc6w-59fv-rh23

    Affected
    • PyPI langchain-community < 0.3.27
    Fixed in
    0.3.27· Vendor fix available
    Issue
    The langchain-ai/langchain project, specifically the EverNoteLoader component, is vulnerable to XML External Entity (XXE) attacks due to insecure XML parsing. The vulnerability arises from the use of etree.iterparse() without disabling external entity references, which can lead to sensitive information disclosure. An attacker could exploit this by crafting a malicious XML payload that references local files, potentially exposing sensitive data such as /etc/passwd. This issue has been fixed in 0.3.27 of langchain-community.

    Recommended action: Upgrade to 0.3.27 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. High, CVSS 8.4PyPIAmendedPublished

    LangChain Community SSRF vulnerability exists in RequestsToolkit component

    CVE-2025-2828 · GHSA-h5gc-rm8j-5gpr

    Affected
    • PyPI langchain-community < 0.0.28
    Fixed in
    0.0.28· Vendor fix available
    Issue
    A Server-Side Request Forgery (SSRF) vulnerability exists in the RequestsToolkit component of the langchain-community package (specifically, langchaincommunity.agenttoolkits.openapi.toolkit.RequestsToolkit) in langchain-ai/langchain version 0.0.27. This vulnerability occurs because the toolkit does not enforce restrictions on requests to remote internet addresses, allowing it to also access local addresses. As a result, an attacker could exploit this flaw to perform port scans, access local services, retrieve instance metadata from cloud environments (e.g., Azure, AWS), and interact with servers on the local network. This issue has been fixed in version 0.0.28.

    Recommended action: Upgrade to 0.0.28 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  3. Low, CVSS 2.1PyPIAmendedPublished

    Langchain SQL Injection vulnerability

    CVE-2024-8309 · GHSA-45pg-36p6-83v9

    Affected
    • PyPI langchain-community >= 0.2.0, < 0.2.19
    Fixed in
    0.2.19· Vendor fix available
    Issue
    A vulnerability in the GraphCypherQAChain class of langchain-ai/langchain version 0.2.5 allows for SQL injection through prompt injection. This vulnerability can lead to unauthorized data manipulation, data exfiltration, denial of service (DoS) by deleting all data, breaches in multi-tenant security environments, and data integrity issues. Attackers can create, update, or delete nodes and relationships without proper authorization, extract sensitive data, disrupt services, access data across different tenants, and compromise the integrity of the database.

    Recommended action: Upgrade to 0.2.19 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  4. High, CVSS 8.4PyPIAmendedPublished

    LangChain pickle deserialization of untrusted data

    CVE-2024-5998 · GHSA-f2jm-rw3h-6phg

    Affected
    • PyPI langchain-community < 0.2.4
    Fixed in
    0.2.4· Vendor fix available
    Issue
    A vulnerability in the FAISS.deserializefrombytes function of langchain-ai/langchain allows for pickle deserialization of untrusted data. This can lead to the execution of arbitrary commands via the os.system function. The issue affects versions prior to 0.2.4.

    Recommended action: Upgrade to 0.2.4 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)osv.dev (2)github.com (3)Source checked Evidence →
  5. Medium, CVSS 4.8PyPIAmendedPublished

    Server-Side Request Forgery in langchain-community.retrievers.web_research.WebResearchRetriever

    CVE-2024-3095 · GHSA-q25c-c977-4cmh

    Affected
    • PyPI langchain-community < 0.2.9
    Fixed in
    0.2.9· Vendor fix available
    Issue
    A Server-Side Request Forgery (SSRF) vulnerability exists in the Web Research Retriever component in langchain-community (langchain-community.retrievers.webresearch.WebResearchRetriever). The vulnerability arises because the Web Research Retriever does not restrict requests to remote internet addresses, allowing it to reach local addresses. This flaw enables attackers to execute port scans, access local services, and in some scenarios, read instance metadata from cloud environments. The vulnerability is particularly concerning as it can be exploited to abuse the Web Explorer server as a proxy for web attacks on third parties and interact with servers in the local network, including reading their response data. This could potentially lead to arbitrary code execution, depending on the nature of the local services. The vulnerability is limited to GET requests, as POST requests are not possible, but the impact on confidentiality, integrity, and availability is significant due to the…

    Recommended action: Upgrade to 0.2.9 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  6. Medium, CVSS 4.2PyPIAmendedPublished

    Denial of service in langchain-community

    CVE-2024-2965 · GHSA-3hjh-jh2h-vrg6

    Affected
    • PyPI langchain-community < 0.2.5
    Fixed in
    0.2.5· Vendor fix available
    Issue
    Denial of service in SitemapLoader Document Loader in the langchain-community package, affecting versions below 0.2.5. The parsesitemap method, responsible for parsing sitemaps and extracting URLs, lacks a mechanism to prevent infinite recursion when a sitemap URL refers to the current sitemap itself. This oversight allows for the possibility of an infinite loop, leading to a crash by exceeding the maximum recursion depth in Python. This vulnerability can be exploited to occupy server socket/port resources and crash the Python process, impacting the availability of services relying on this functionality.

    Recommended action: Upgrade to 0.2.5 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →