Denial of service in langchain-community
CVE-2024-2965GHSA-3hjh-jh2h-vrg6
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (langchain 0.2.5; langchain-community 0.2.5), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI langchain
- Affected
- < 0.2.5
- Fixed in
- 0.2.5
PyPI langchain-community
- Affected
- < 0.2.5
- Fixed in
- 0.2.5
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-3hjh-jh2h-vrg6 lists affected ranges: PyPI langchain-community >=0 =0 <0.2.5 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-3hjh-jh2h-vrg6 lists affected ranges: PyPI langchain-community >=0 =0 <0.2.5
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.2 · CVSS:3.0/AV:P/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2024-2965: 0.30% estimated exploitation activity in the next 30 days; percentile 23.23 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Denial of service in SitemapLoader Document Loader in the langchain-community package, affecting versions below 0.2.5. The parsesitemap method, responsible for parsing sitemaps and extracting URLs, lacks a mechanism to prevent infinite recursion when a sitemap URL refers to the current sitemap itself. This oversight allows for the possibility of an infinite loop, leading to a crash by exceeding the maximum recursion depth in Python. This vulnerability can be exploited to occupy server socket/port resources and crash the Python process, impacting the availability of services relying on this functionality.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-3hjh-jh2h-vrg6
- Revision 1 · created ·
Published from osv record GHSA-3hjh-jh2h-vrg6
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-2965 Advisory: Denial of service in langchain-community IDs: CVE-2024-2965, GHSA-3hjh-jh2h-vrg6 Record: https://patchnext.com/advisories/cve-2024-2965 (revision 2, source checked 26 Oct 2026, 13:26 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: langchain 0.2.5; langchain-community 0.2.5. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI langchain: affected < 0.2.5; fixed in 0.2.5 - PyPI langchain-community: affected < 0.2.5; fixed in 0.2.5 ## Suggested inspection (read-only) - `python -m pip show langchain`: prints the installed version. Run with the environment that serves production active. - `python -m pip show langchain-community`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on langchain, langchain-community. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-3hjh-jh2h-vrg6 (OSV record GHSA-3hjh-jh2h-vrg6 lists affected ranges: PyPI langchain-community >=0 =0 <0.2.5 (fixed)) - Verified: https://github.com/advisories/GHSA-3hjh-jh2h-vrg6 (GitHub-reviewed advisory GHSA-3hjh-jh2h-vrg6 lists affected ranges: PyPI langchain-community >=0 =0 <0.2.5) Commands are suggestions: review each one before running it.
Loading voting…