Server-Side Request Forgery in langchain-community.retrievers.web_research.WebResearchRetriever
CVE-2024-3095GHSA-q25c-c977-4cmh
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (langchain-community 0.2.9), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI langchain-community
- Affected
- < 0.2.9
- Fixed in
- 0.2.9
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-q25c-c977-4cmh lists affected ranges: PyPI langchain-community >=0 <0.2.9 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-q25c-c977-4cmh lists affected ranges: PyPI langchain-community >=0 <0.2.9
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.8 · CVSS:3.0/AV:P/AC:H/PR:L/UI:N/S:C/C:H/I:N/A:N
- EPSS
- CVE-2024-3095: 0.69% estimated exploitation activity in the next 30 days; percentile 52.86 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A Server-Side Request Forgery (SSRF) vulnerability exists in the Web Research Retriever component in langchain-community (langchain-community.retrievers.webresearch.WebResearchRetriever). The vulnerability arises because the Web Research Retriever does not restrict requests to remote internet addresses, allowing it to reach local addresses. This flaw enables attackers to execute port scans, access local services, and in some scenarios, read instance metadata from cloud environments. The vulnerability is particularly concerning as it can be exploited to abuse the Web Explorer server as a proxy for web attacks on third parties and interact with servers in the local network, including reading their response data. This could potentially lead to arbitrary code execution, depending on the nature of the local services. The vulnerability is limited to GET requests, as POST requests are not possible, but the impact on confidentiality, integrity, and availability is significant due to the…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-q25c-c977-4cmh
- Revision 1 · created ·
Published from osv record GHSA-q25c-c977-4cmh
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-3095 Advisory: Server-Side Request Forgery in langchain-community.retrievers.web_research.WebResearchRetriever IDs: CVE-2024-3095, GHSA-q25c-c977-4cmh Record: https://patchnext.com/advisories/cve-2024-3095 (revision 2, source checked 26 Oct 2026, 13:16 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: langchain-community 0.2.9. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI langchain-community: affected < 0.2.9; fixed in 0.2.9 ## Suggested inspection (read-only) - `python -m pip show langchain-community`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on langchain-community. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-q25c-c977-4cmh (OSV record GHSA-q25c-c977-4cmh lists affected ranges: PyPI langchain-community >=0 <0.2.9 (fixed)) - Verified: https://github.com/advisories/GHSA-q25c-c977-4cmh (GitHub-reviewed advisory GHSA-q25c-c977-4cmh lists affected ranges: PyPI langchain-community >=0 <0.2.9) Commands are suggestions: review each one before running it.
Loading voting…