Langchain Community Vulnerable to XML External Entity (XXE) Attacks
CVE-2025-6984GHSA-pc6w-59fv-rh23
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (langchain-community 0.3.27), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI langchain-community
- Affected
- < 0.3.27
- Fixed in
- 0.3.27
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-pc6w-59fv-rh23 lists affected ranges: PyPI langchain-community >=0 <0.3.27 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-pc6w-59fv-rh23 lists affected ranges: PyPI langchain-community >=0 <0.3.27
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- EPSS
- CVE-2025-6984: 1.65% estimated exploitation activity in the next 30 days; percentile 76.50 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The langchain-ai/langchain project, specifically the EverNoteLoader component, is vulnerable to XML External Entity (XXE) attacks due to insecure XML parsing. The vulnerability arises from the use of etree.iterparse() without disabling external entity references, which can lead to sensitive information disclosure. An attacker could exploit this by crafting a malicious XML payload that references local files, potentially exposing sensitive data such as /etc/passwd. This issue has been fixed in 0.3.27 of langchain-community.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-pc6w-59fv-rh23
- Revision 1 · created ·
Published from osv record GHSA-pc6w-59fv-rh23
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-6984 Advisory: Langchain Community Vulnerable to XML External Entity (XXE) Attacks IDs: CVE-2025-6984, GHSA-pc6w-59fv-rh23 Record: https://patchnext.com/advisories/cve-2025-6984 (revision 2, source checked 26 Oct 2026, 13:35 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: langchain-community 0.3.27. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI langchain-community: affected < 0.3.27; fixed in 0.3.27 ## Suggested inspection (read-only) - `python -m pip show langchain-community`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on langchain-community. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-pc6w-59fv-rh23 (OSV record GHSA-pc6w-59fv-rh23 lists affected ranges: PyPI langchain-community >=0 <0.3.27 (fixed)) - Verified: https://github.com/advisories/GHSA-pc6w-59fv-rh23 (GitHub-reviewed advisory GHSA-pc6w-59fv-rh23 lists affected ranges: PyPI langchain-community >=0 <0.3.27) Commands are suggestions: review each one before running it.
Loading voting…