Skip to content

← Public intelligence

PyPI package

ironic

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

8 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 6.8PyPIAmendedPublished

    OpenStack Ironic can return unredacted sensitive information when applying a PATCH to update fields in volume properties

    CVE-2026-54421 · GHSA-j4cw-mcg2-2q78

    Affected
    • PyPI ironic >= 17.0.0, < 29.0.6; >= 30.0.0, < 32.0.2; >= 33.0.0, < 35.0.2; >= 36.0.0, < 37.0.1
    Fixed in
    32.0.237.0.129.0.635.0.2· Vendor fix available
    Issue
    In OpenStack Ironic through 35.0.1, when applying a PATCH to update fields in volume properties the user is authorized for, Ironic can return unredacted sensitive information (such as iSCSI credentials). The PATCH outcome is a security issue; the POST outcome is not a security issue.

    Recommended action: Upgrade to 37.0.1, 35.0.2, 32.0.2 or 29.0.6 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. Medium, CVSS 5.3PyPIAmendedPublished

    OpenStack Ironic: Crafted JSON String to Certain Endpoints on the API or JSON-RPC Service May Result in Service Crash

    CVE-2026-50589 · GHSA-q3g8-rjrx-59ph

    Affected
    • PyPI ironic >= 32.0.0, < 37.0.0
    Fixed in
    37.0.0· Vendor fix available
    Issue
    In OpenStack Ironic 32.0.0 through 35.0.1, an unauthenticated malicious user could submit a crafted JSON string to some endpoints on the API or JSON-RPC service and effect a service crash.

    Recommended action: Upgrade to 37.0.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  3. Medium, CVSS 5.9PyPIAmendedPublished

    OpenStack Ironic allows file overwrite via directory traversal during deployment with a crafted ISO image

    CVE-2026-48681 · GHSA-9v62-qx4c-44x5

    Affected
    • PyPI ironic >= 17.0.0, < 26.1.7; >= 27.0.0, < 29.0.6; >= 30.0.0, < 32.0.2; >= 33.0.0, < 35.0.2
    Fixed in
    32.0.226.1.729.0.635.0.2· Vendor fix available
    Issue
    OpenStack Ironic through before 35.0.2 allows file overwrite via directory traversal during deployment with a crafted ISO image.

    Recommended action: Upgrade to 35.0.2, 32.0.2, 29.0.6 or 26.1.7 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  4. Medium, CVSS 5.8PyPIAmendedPublished

    OpenStack Ironic allows Boot Script Injection

    CVE-2026-46447 · GHSA-jrh2-f5jc-xpgr

    Affected
    • PyPI ironic >= 17.0.0, < 26.1.7; >= 27.0.0, < 29.0.6; >= 30.0.0, < 32.0.2; >= 33.0.0, < 35.0.2
    Fixed in
    32.0.226.1.729.0.635.0.2· Vendor fix available
    Issue
    OpenStack Ironic through 35.0.x allows Boot Script Injection.

    Recommended action: Upgrade to 35.0.2, 32.0.2, 29.0.6 or 26.1.7 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  5. Medium, CVSS 6.6PyPIAmendedPublished

    OpenStack Ironic is Vulnerable to Inclusion of Functionality from Untrusted Control Sphere

    CVE-2026-42510 · GHSA-wqpv-c3pp-3m58

    Affected
    • PyPI ironic < 35.0.1
    Fixed in
    35.0.1· Vendor fix available
    Issue
    OpenStack Ironic before 35.0.1 allows ipmitool execution in a non-default configuration that has a console interface.

    Recommended action: Upgrade to 35.0.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  6. Low, CVSS 2.8PyPIAmendedPublished

    OpenStack Ironic fails to restrict paths used for file:// image URLs

    CVE-2025-44021 · GHSA-q3m2-crgq-5p3q

    Affected
    • PyPI ironic < 24.1.3; >= 25.0.0, < 26.1.1; >= 27.0.0, < 29.0.1
    Fixed in
    29.0.124.1.326.1.1· Vendor fix available
    Issue
    OpenStack Ironic before 29.0.1 can write unintended files to a target node disk during image handling (if a deployment was performed via the API). A malicious project assigned as a node owner can provide a path to any local file (readable by ironic-conductor), which may then be written to the target node disk. This is difficult to exploit in practice, because a node deployed in this manner should never reach the ACTIVE state, but it still represents a danger in environments running with non-default, insecure configurations such as with automated cleaning disabled. The fixed versions are 24.1.3, 26.1.1, and 29.0.1.

    Recommended action: Upgrade to 29.0.1, 26.1.1 or 24.1.3 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  7. Medium, CVSS 6.9PyPIAmendedPublished

    OpenStack Ironic fails to verify checksums of supplied image_source URLs

    CVE-2024-47211 · GHSA-8h22-6qwx-q4w9

    Affected
    • PyPI ironic >= 25.0.0, < 26.1.1; >= 23.1.0, < 24.1.3; >= 22.0.0, < 23.0.3; <= 21.4.3
    Fixed in
    23.0.324.1.326.1.1· Partial vendor fix
    Issue
    In OpenStack Ironic before 21.4.4, 22.x and 23.x before 23.0.3, 23.x and 24.x before 24.1.3, and 25.x and 26.x before 26.1.0, there is a lack of checksum validation of supplied imagesource URLs when configured to convert images to a raw format for streaming.

    Recommended action: Upgrade to 26.1.1, 24.1.3 or 23.0.3 by release line; some affected versions have no fix yet, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  8. High, CVSS 7.5PyPIAmendedPublished

    OpenStack Ironic Exposure of Sensitive Information to an Unauthorized Actor

    CVE-2016-4985 · GHSA-f7cr-7c2c-fm8r

    Affected
    • PyPI ironic < 4.2.5; >= 5.0, < 5.1.2
    Fixed in
    4.2.55.1.2· Vendor fix available
    Issue
    The ironic-api service in OpenStack Ironic before 4.2.5 (Liberty) and 5.x before 5.1.2 (Mitaka) allows remote attackers to obtain sensitive information about a registered node by leveraging knowledge of the MAC address of a network card belonging to that node and sending a crafted POST request to the v1/drivers/$DRIVERNAME/vendorpassthru resource.

    Recommended action: Upgrade to 5.1.2 or 4.2.5 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →