OpenStack Ironic: Crafted JSON String to Certain Endpoints on the API or JSON-RPC Service May Result in Service Crash
CVE-2026-50589GHSA-q3g8-rjrx-59ph
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (ironic 37.0.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI ironic
- Affected
- >= 32.0.0, < 37.0.0
- Fixed in
- 37.0.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-q3g8-rjrx-59ph lists affected ranges: PyPI ironic >=32.0.0 <37.0.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-q3g8-rjrx-59ph lists affected ranges: PyPI ironic >=32.0.0 <37.0.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
- EPSS
- CVE-2026-50589: 0.43% estimated exploitation activity in the next 30 days; percentile 37.66 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
In OpenStack Ironic 32.0.0 through 35.0.1, an unauthenticated malicious user could submit a crafted JSON string to some endpoints on the API or JSON-RPC service and effect a service crash.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-q3g8-rjrx-59ph
- Revision 1 · created ·
Published from osv record GHSA-q3g8-rjrx-59ph
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-50589 Advisory: OpenStack Ironic: Crafted JSON String to Certain Endpoints on the API or JSON-RPC Service May Result in Service Crash IDs: CVE-2026-50589, GHSA-q3g8-rjrx-59ph Record: https://patchnext.com/advisories/cve-2026-50589 (revision 2, source checked 26 Oct 2026, 13:46 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: ironic 37.0.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI ironic: affected >= 32.0.0, < 37.0.0; fixed in 37.0.0 ## Suggested inspection (read-only) - `python -m pip show ironic`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on ironic. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-q3g8-rjrx-59ph (OSV record GHSA-q3g8-rjrx-59ph lists affected ranges: PyPI ironic >=32.0.0 <37.0.0 (fixed)) - Verified: https://github.com/advisories/GHSA-q3g8-rjrx-59ph (GitHub-reviewed advisory GHSA-q3g8-rjrx-59ph lists affected ranges: PyPI ironic >=32.0.0 <37.0.0) Commands are suggestions: review each one before running it.
Loading voting…