OpenStack Ironic fails to restrict paths used for file:// image URLs
CVE-2025-44021GHSA-q3m2-crgq-5p3q
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (ironic 29.0.1, 26.1.1, 24.1.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI ironic
- Affected
- < 24.1.3>= 25.0.0, < 26.1.1>= 27.0.0, < 29.0.1
- Fixed in
- 29.0.1, 24.1.3, 26.1.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-q3m2-crgq-5p3q lists affected ranges: PyPI ironic >=0 =25.0.0 =27.0.0 <29.0.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-q3m2-crgq-5p3q lists affected ranges: PyPI ironic >=0 =25.0.0 =27.0.0 <29.0.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 2.8 · CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:C/C:N/I:L/A:N
- EPSS
- CVE-2025-44021: 0.19% estimated exploitation activity in the next 30 days; percentile 8.74 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
OpenStack Ironic before 29.0.1 can write unintended files to a target node disk during image handling (if a deployment was performed via the API). A malicious project assigned as a node owner can provide a path to any local file (readable by ironic-conductor), which may then be written to the target node disk. This is difficult to exploit in practice, because a node deployed in this manner should never reach the ACTIVE state, but it still represents a danger in environments running with non-default, insecure configurations such as with automated cleaning disabled. The fixed versions are 24.1.3, 26.1.1, and 29.0.1.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-q3m2-crgq-5p3q
- Revision 1 · created ·
Published from osv record GHSA-q3m2-crgq-5p3q
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-44021 Advisory: OpenStack Ironic fails to restrict paths used for file:// image URLs IDs: CVE-2025-44021, GHSA-q3m2-crgq-5p3q Record: https://patchnext.com/advisories/cve-2025-44021 (revision 2, source checked 26 Oct 2026, 13:32 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 2.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: ironic 29.0.1, 26.1.1, 24.1.3. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI ironic: affected < 24.1.3; >= 25.0.0, < 26.1.1; >= 27.0.0, < 29.0.1; fixed in 29.0.1, 24.1.3, 26.1.1 ## Suggested inspection (read-only) - `python -m pip show ironic`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on ironic. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-q3m2-crgq-5p3q (OSV record GHSA-q3m2-crgq-5p3q lists affected ranges: PyPI ironic >=0 =25.0.0 =27.0.0 <29.0.1 (fixed)) - Verified: https://github.com/advisories/GHSA-q3m2-crgq-5p3q (GitHub-reviewed advisory GHSA-q3m2-crgq-5p3q lists affected ranges: PyPI ironic >=0 =25.0.0 =27.0.0 <29.0.1) Commands are suggestions: review each one before running it.
Loading voting…