OpenStack Ironic fails to verify checksums of supplied image_source URLs
CVE-2024-47211GHSA-8h22-6qwx-q4w9
What to do
Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI ironic
- Affected
- >= 25.0.0, < 26.1.1>= 23.1.0, < 24.1.3>= 22.0.0, < 23.0.3<= 21.4.3
- Fixed in
- 23.0.3, 24.1.3, 26.1.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-8h22-6qwx-q4w9 lists affected ranges: PyPI ironic >=25.0.0 =23.1.0 =22.0.0 =0 <=21.4.3
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-8h22-6qwx-q4w9 lists affected ranges: PyPI ironic >=25.0.0 =23.1.0 =22.0.0 =0 <=21.4.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2024-47211: 0.66% estimated exploitation activity in the next 30 days; percentile 51.76 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
In OpenStack Ironic before 21.4.4, 22.x and 23.x before 23.0.3, 23.x and 24.x before 24.1.3, and 25.x and 26.x before 26.1.0, there is a lack of checksum validation of supplied imagesource URLs when configured to convert images to a raw format for streaming.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-8h22-6qwx-q4w9
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-8h22-6qwx-q4w9
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-47211 Advisory: OpenStack Ironic fails to verify checksums of supplied image_source URLs IDs: CVE-2024-47211, GHSA-8h22-6qwx-q4w9 Record: https://patchnext.com/advisories/cve-2024-47211 (revision 3, source checked 26 Oct 2026, 13:26 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Partial vendor fix; fixed versions by package: ironic 26.1.1, 24.1.3, 23.0.3. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI ironic: affected >= 25.0.0, < 26.1.1; >= 23.1.0, < 24.1.3; >= 22.0.0, < 23.0.3; <= 21.4.3; fixed in 23.0.3, 24.1.3, 26.1.1 ## Suggested inspection (read-only) - `python -m pip show ironic`: prints the installed version. Run with the environment that serves production active. ## Supported action No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on ironic. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-8h22-6qwx-q4w9 (OSV record GHSA-8h22-6qwx-q4w9 lists affected ranges: PyPI ironic >=25.0.0 =23.1.0 =22.0.0 =0 <=21.4.3) - Verified: https://github.com/advisories/GHSA-8h22-6qwx-q4w9 (GitHub-reviewed advisory GHSA-8h22-6qwx-q4w9 lists affected ranges: PyPI ironic >=25.0.0 =23.1.0 =22.0.0 =0 <=21.4.3) Commands are suggestions: review each one before running it.
Loading voting…