Skip to content

← Public intelligence

PyPI package

feast

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

3 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Critical, CVSS 9.9PyPIAmendedPublished

    Feast vulnerable to arbitrary code execution via unsafe deserialization of dill-serialized UDFs

    CVE-2026-18948 · GHSA-gg2p-37pv-v7fq

    Affected
    • PyPI feast < 0.67.0
    Fixed in
    0.67.0· Vendor fix available
    Issue
    A flaw was found in Feast. The system improperly deserializes user-defined functions (UDFs) stored in its registry, which are serialized using the 'dill' library. This allows a remote attacker to store a malicious UDF, leading to unauthenticated arbitrary code execution on the feature server in default configurations. An authenticated attacker can also achieve arbitrary code execution on the registry server by bypassing authorization checks during deserialization. This vulnerability can result in cross-tenant data access and lateral movement within the system.

    Recommended action: Upgrade to 0.67.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.com (1)osv.dev (2)Source checked Evidence →
  2. Critical, CVSS 9.3PyPIAmendedPublished

    Feast vulnerable to unsafe deserialization RCE in registry server via UDF proto

    CVE-2026-56121 · GHSA-q63x-9pfm-mjx4

    Affected
    • PyPI feast < 0.63.0
    Fixed in
    0.63.0· Vendor fix available
    Issue
    Feast before 0.63.0 contains an unsafe deserialization vulnerability that allows unauthenticated or unauthorized attackers to achieve remote code execution by sending a crafted gRPC request to the registry server. The user_defined_function.body field of an OnDemandFeatureView spec is decoded from base64 and passed to dill.loads() before any authorization check is performed, enabling attackers to embed a malicious serialized Python object with an arbitrary reduce method to execute OS commands as the feast service account.

    Recommended action: Upgrade to 0.63.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.com (1)osv.dev (2)Source checked Evidence →
  3. High, CVSS 7.8PyPIAmendedPublished

    Feast vulnerable to Deserialization of Untrusted Data

    CVE-2025-11157 · GHSA-34wm-4hw7-qfjv

    Affected
    • PyPI feast < 0.54.0
    Fixed in
    0.54.0· Vendor fix available
    Issue
    A high-severity remote code execution vulnerability exists in feast-dev/feast version 0.53.0, specifically in the Kubernetes materializer job located at feast/sdk/python/feast/infra/computeengines/kubernetes/main.py. The vulnerability arises from the use of yaml.load(..., Loader=yaml.Loader) to deserialize /var/feast/featurestore.yaml and /var/feast/materializationconfig.yaml. This method allows for the instantiation of arbitrary Python objects, enabling an attacker with the ability to modify these YAML files to execute OS commands on the worker pod. This vulnerability can be exploited before the configuration is validated, potentially leading to cluster takeover, data poisoning, and supply-chain sabotage.

    Recommended action: Upgrade to 0.54.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →