Skip to content

← Actionable
High, CVSS 7.8amended

Feast vulnerable to Deserialization of Untrusted Data

CVE-2025-11157GHSA-34wm-4hw7-qfjv

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (feast 0.54.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI feast

    Affected
    < 0.54.0
    Fixed in
    0.54.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.8 · CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2025-11157: 0.30% estimated exploitation activity in the next 30 days; percentile 22.34 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A high-severity remote code execution vulnerability exists in feast-dev/feast version 0.53.0, specifically in the Kubernetes materializer job located at feast/sdk/python/feast/infra/computeengines/kubernetes/main.py. The vulnerability arises from the use of yaml.load(..., Loader=yaml.Loader) to deserialize /var/feast/featurestore.yaml and /var/feast/materializationconfig.yaml. This method allows for the instantiation of arbitrary Python objects, enabling an attacker with the ability to modify these YAML files to execute OS commands on the worker pod. This vulnerability can be exploited before the configuration is validated, potentially leading to cluster takeover, data poisoning, and supply-chain sabotage.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-34wm-4hw7-qfjv

  2. Revision 1 · created ·

    Published from osv record GHSA-34wm-4hw7-qfjv

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-11157

Advisory: Feast vulnerable to Deserialization of Untrusted Data
IDs: CVE-2025-11157, GHSA-34wm-4hw7-qfjv
Record: https://patchnext.com/advisories/cve-2025-11157 (revision 2, source checked 26 Oct 2026, 13:36 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: feast 0.54.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI feast: affected < 0.54.0; fixed in 0.54.0

## Suggested inspection (read-only)
- `python -m pip show feast`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on feast.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-34wm-4hw7-qfjv (OSV record GHSA-34wm-4hw7-qfjv lists affected ranges: PyPI feast >=0 <0.54.0 (fixed))
- Verified: https://github.com/advisories/GHSA-34wm-4hw7-qfjv (GitHub-reviewed advisory GHSA-34wm-4hw7-qfjv lists affected ranges: PyPI feast >=0 <0.54.0)

Commands are suggestions: review each one before running it.

Loading voting…