Skip to content

← Actionable
Critical, CVSS 9.9amended

Feast vulnerable to arbitrary code execution via unsafe deserialization of dill-serialized UDFs

CVE-2026-18948GHSA-gg2p-37pv-v7fq

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (feast 0.67.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI feast

    Affected
    < 0.67.0
    Fixed in
    0.67.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.9 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
EPSS
  • CVE-2026-18948: 1.08% estimated exploitation activity in the next 30 days; percentile 65.11 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A flaw was found in Feast. The system improperly deserializes user-defined functions (UDFs) stored in its registry, which are serialized using the 'dill' library. This allows a remote attacker to store a malicious UDF, leading to unauthenticated arbitrary code execution on the feature server in default configurations. An authenticated attacker can also achieve arbitrary code execution on the registry server by bypassing authorization checks during deserialization. This vulnerability can result in cross-tenant data access and lateral movement within the system.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from osv record GHSA-gg2p-37pv-v7fq

  2. Revision 1 · created ·

    Published from ghsa record GHSA-gg2p-37pv-v7fq

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-18948

Advisory: Feast vulnerable to arbitrary code execution via unsafe deserialization of dill-serialized UDFs
IDs: CVE-2026-18948, GHSA-gg2p-37pv-v7fq
Record: https://patchnext.com/advisories/cve-2026-18948 (revision 2, source checked 4 Nov 2026, 06:20 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: feast 0.67.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI feast: affected < 0.67.0; fixed in 0.67.0

## Suggested inspection (read-only)
- `python -m pip show feast`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on feast.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-gg2p-37pv-v7fq (GitHub-reviewed advisory GHSA-gg2p-37pv-v7fq lists affected ranges: PyPI feast >=0 <0.67.0)
- Verified: https://osv.dev/vulnerability/GHSA-gg2p-37pv-v7fq (OSV record GHSA-gg2p-37pv-v7fq lists affected ranges: PyPI feast >=0 <0.67.0 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…