Feast vulnerable to unsafe deserialization RCE in registry server via UDF proto
CVE-2026-56121GHSA-q63x-9pfm-mjx4
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (feast 0.63.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI feast
- Affected
- < 0.63.0
- Fixed in
- 0.63.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-q63x-9pfm-mjx4 lists affected ranges: PyPI feast >=0 <0.63.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-q63x-9pfm-mjx4 lists affected ranges: PyPI feast >=0 <0.63.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 9.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-56121: 1.41% estimated exploitation activity in the next 30 days; percentile 72.63 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Feast before 0.63.0 contains an unsafe deserialization vulnerability that allows unauthenticated or unauthorized attackers to achieve remote code execution by sending a crafted gRPC request to the registry server. The user_defined_function.body field of an OnDemandFeatureView spec is decoded from base64 and passed to dill.loads() before any authorization check is performed, enabling attackers to embed a malicious serialized Python object with an arbitrary reduce method to execute OS commands as the feast service account.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from osv record GHSA-q63x-9pfm-mjx4
- Revision 1 · created ·
Published from ghsa record GHSA-q63x-9pfm-mjx4
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-56121 Advisory: Feast vulnerable to unsafe deserialization RCE in registry server via UDF proto IDs: CVE-2026-56121, GHSA-q63x-9pfm-mjx4 Record: https://patchnext.com/advisories/cve-2026-56121 (revision 2, source checked 4 Nov 2026, 06:20 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: feast 0.63.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI feast: affected < 0.63.0; fixed in 0.63.0 ## Suggested inspection (read-only) - `python -m pip show feast`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on feast. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-q63x-9pfm-mjx4 (GitHub-reviewed advisory GHSA-q63x-9pfm-mjx4 lists affected ranges: PyPI feast >=0 <0.63.0) - Verified: https://osv.dev/vulnerability/GHSA-q63x-9pfm-mjx4 (OSV record GHSA-q63x-9pfm-mjx4 lists affected ranges: PyPI feast >=0 <0.63.0 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…