Skip to content

← Public intelligence

Packagist package

zendframework/zendframework1

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

33 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 7.3PackagistPublished

    Zend Framework XXE Vulnerability

    CVE-2012-3363 · GHSA-7pg4-5233-82jv

    Affected
    • Packagist zendframework/zendframework1 >= 1.12.0-rc1, < 1.12.0; >= 1.0.0, < 1.11.12
    Fixed in
    1.12.01.11.12· Vendor fix available
    Issue
    ZendXmlRpc in Zend Framework 1.x before 1.11.12 and 1.12.x before 1.12.0 does not properly handle SimpleXMLElement classes, which allows remote attackers to read arbitrary files or create TCP connections via an external entity reference in a DOCTYPE element in an XML-RPC request, aka an XML external entity (XXE) injection attack.

    Recommended action: Upgrade to 1.12.0 or 1.11.12 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Critical, CVSS 9.8PackagistPublished

    Zend Framework SQL injection vector using null byte for PDO

    CVE-2015-7695 · GHSA-2hvh-c5c2-vj85

    Affected
    • Packagist zendframework/zendframework1 < 1.12.16
    Fixed in
    1.12.16· Vendor fix available
    Issue
    The PDO adapters in Zend Framework before 1.12.16 do not filer null bytes in SQL statements, which allows remote attackers to execute arbitrary SQL commands via a crafted query.

    Recommended action: Upgrade to 1.12.16 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. UnratedPackagistPublished

    ZendXml and Zend Framework contain XXE and XEE Vulnerabilities

    CVE-2015-5161 · GHSA-xp8p-9rq5-4wgv

    Affected
    • Packagist zendframework/zendframework1 >= 1.12.0, < 1.12.14
    Fixed in
    1.12.14· Vendor fix available
    Issue
    The ZendXmlSecurity::scan in ZendXml before 1.0.1 and Zend Framework before 1.12.14, 2.x before 2.4.6, and 2.5.x before 2.5.2, when running under PHP-FPM in a threaded environment, allows remote attackers to bypass security checks and conduct XML external entity (XXE) and XML entity expansion (XEE) attacks via multibyte encoded characters.

    Recommended action: Upgrade to 1.12.14 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  4. UnratedPackagistPublished

    Zend Access Restriction Bypass

    CVE-2014-8088 · GHSA-f6rc-rh43-h8gr

    Affected
    • Packagist zendframework/zendframework1 >= 1.12.0, < 1.12.9
    Fixed in
    1.12.9· Vendor fix available
    Issue
    The (1) ZendLdap class in Zend before 1.12.9 and (2) Zend\Ldap component in Zend 2.x before 2.2.8 and 2.3.x before 2.3.3 allows remote attackers to bypass authentication via a password starting with a null byte, which triggers an unauthenticated bind.

    Recommended action: Upgrade to 1.12.9 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  5. Critical, CVSS 9.8PackagistPublished

    Zend Framework Allows SQL Injection

    CVE-2016-6233 · GHSA-p9hp-3gpv-52w3

    Affected
    • Packagist zendframework/zendframework1 < 1.12.19
    Fixed in
    1.12.19· Vendor fix available
    Issue
    The (1) order and (2) group methods in ZendDbSelect in the Zend Framework before 1.12.19 might allow remote attackers to conduct SQL injection attacks via vectors related to use of the character pattern [\w] in a regular expression.

    Recommended action: Upgrade to 1.12.19 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  6. UnratedPackagistPublished

    Several Zend Products Vulnerable to XXE and XEE attacks

    CVE-2014-2683 · GHSA-5wm2-38q5-5rxv

    Affected
    • Packagist zendframework/zendframework1 < 1.12.4
    Fixed in
    1.12.4· Vendor fix available
    Issue
    Zend Framework 1 (ZF1) before 1.12.4, Zend Framework 2 before 2.1.6 and 2.2.x before 2.2.6, ZendOpenId, ZendRest, ZendServiceAudioScrobbler, ZendServiceNirvanix, ZendServiceSlideShare, ZendServiceTechnorati, and ZendServiceWindowsAzure before 2.0.2, ZendServiceAmazon before 2.0.3, and ZendServiceApi before 1.0.0 allow remote attackers to cause a denial of service (CPU consumption) via (1) recursive or (2) circular references in an XML entity definition in an XML DOCTYPE declaration, aka an XML Entity Expansion (XEE) attack. NOTE: this issue exists because of an incomplete fix for CVE-2012-6532.

    Recommended action: Upgrade to 1.12.4 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  7. UnratedPackagistPublished

    Several Zend Products Vulnerable to XXE and XEE attacks

    CVE-2014-2681 · GHSA-43xg-87xw-jpv8

    Affected
    • Packagist zendframework/zendframework1 < 1.12.4
    Fixed in
    1.12.4· Vendor fix available
    Issue
    Zend Framework 1 (ZF1) before 1.12.4, Zend Framework 2 before 2.1.6 and 2.2.x before 2.2.6, ZendOpenId, ZendRest, ZendServiceAudioScrobbler, ZendServiceNirvanix, ZendServiceSlideShare, ZendServiceTechnorati, and ZendServiceWindowsAzure before 2.0.2, ZendServiceAmazon before 2.0.3, and ZendServiceApi before 1.0.0 allow remote attackers to read arbitrary files, send HTTP requests to intranet servers, and possibly cause a denial of service (CPU and memory consumption) via an XML External Entity (XXE) attack. NOTE: this issue exists because of an incomplete fix for CVE-2012-5657.

    Recommended action: Upgrade to 1.12.4 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  8. UnratedPackagistPublished

    Several Zend Products Vulnerable to XXE and XEE attacks

    CVE-2014-2682 · GHSA-gp39-h9c2-qw79

    Affected
    • Packagist zendframework/zendframework1 < 1.12.4
    Fixed in
    1.12.4· Vendor fix available
    Issue
    Zend Framework 1 (ZF1) before 1.12.4, Zend Framework 2 before 2.1.6 and 2.2.x before 2.2.6, ZendOpenId, ZendRest, ZendServiceAudioScrobbler, ZendServiceNirvanix, ZendServiceSlideShare, ZendServiceTechnorati, and ZendServiceWindowsAzure before 2.0.2, ZendServiceAmazon before 2.0.3, and ZendServiceApi before 1.0.0, when PHP-FPM is used, does not properly share the libxmldisableentityloader setting between threads, which might allow remote attackers to conduct XML External Entity (XXE) attacks via an XML external entity declaration in conjunction with an entity reference. NOTE: this issue exists because of an incomplete fix for CVE-2012-5657.

    Recommended action: Upgrade to 1.12.4 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →