Zend Framework SQL injection vector using null byte for PDO
CVE-2015-7695GHSA-2hvh-c5c2-vj85
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (zendframework/zendframework1 1.12.16), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist zendframework/zendframework1
- Affected
- < 1.12.16
- Fixed in
- 1.12.16
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-2hvh-c5c2-vj85 lists affected ranges: Packagist zendframework/zendframework1 >=0 <1.12.16
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2015-7695: 2.89% estimated exploitation activity in the next 30 days; percentile 86.92 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The PDO adapters in Zend Framework before 1.12.16 do not filer null bytes in SQL statements, which allows remote attackers to execute arbitrary SQL commands via a crafted query.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-2hvh-c5c2-vj85
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2015-7695 Advisory: Zend Framework SQL injection vector using null byte for PDO IDs: CVE-2015-7695, GHSA-2hvh-c5c2-vj85 Record: https://patchnext.com/advisories/cve-2015-7695 (revision 1, source checked 26 Oct 2026, 14:19 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: zendframework/zendframework1 1.12.16. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist zendframework/zendframework1: affected < 1.12.16; fixed in 1.12.16 ## Suggested inspection (read-only) - Packagist zendframework/zendframework1: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on zendframework/zendframework1. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-2hvh-c5c2-vj85 (GitHub-reviewed advisory GHSA-2hvh-c5c2-vj85 lists affected ranges: Packagist zendframework/zendframework1 >=0 <1.12.16) Commands are suggestions: review each one before running it.
Loading voting…