Skip to content

← Actionable
Unrated

Several Zend Products Vulnerable to XXE and XEE attacks

CVE-2014-2683GHSA-5wm2-38q5-5rxv

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (zendframework/zendservice-amazon 2.0.3; zendframework/zendservice-api 1.0.0; zendframework/zendservice-technorati 2.0.2; zendframework/zendrest 2.0.2; zendframework/zendservice-windowsazure 2.0.2; 5 more packages under Affected packages), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-5wm2-38q5-5rxv lists affected ranges: Packagist zendframework/zendframework1 >=0 =0 =0 =0 =0 =0 =0 <2.0.2; Packagist zendframework/zendservice-windowsazure…

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
not scored
EPSS
  • CVE-2014-2683: 2.35% estimated exploitation activity in the next 30 days; percentile 83.74 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Zend Framework 1 (ZF1) before 1.12.4, Zend Framework 2 before 2.1.6 and 2.2.x before 2.2.6, ZendOpenId, ZendRest, ZendServiceAudioScrobbler, ZendServiceNirvanix, ZendServiceSlideShare, ZendServiceTechnorati, and ZendServiceWindowsAzure before 2.0.2, ZendServiceAmazon before 2.0.3, and ZendServiceApi before 1.0.0 allow remote attackers to cause a denial of service (CPU consumption) via (1) recursive or (2) circular references in an XML entity definition in an XML DOCTYPE declaration, aka an XML Entity Expansion (XEE) attack. NOTE: this issue exists because of an incomplete fix for CVE-2012-6532.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-5wm2-38q5-5rxv

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2014-2683

Advisory: Several Zend Products Vulnerable to XXE and XEE attacks
IDs: CVE-2014-2683, GHSA-5wm2-38q5-5rxv
Record: https://patchnext.com/advisories/cve-2014-2683 (revision 1, source checked 26 Oct 2026, 14:09 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Unrated
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: zendframework/zendservice-amazon 2.0.3; zendframework/zendservice-api 1.0.0; zendframework/zendservice-technorati 2.0.2; zendframework/zendrest 2.0.2; zendframework/zendservice-windowsazure 2.0.2; zendframework/zendservice-slideshare 2.0.2; zendframework/zendservice-audioscrobbler 2.0.2; zendframework/zendframework1 1.12.4; zendframework/zendservice-nirvanix 2.0.2; zendframework/zendopenid 2.0.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist zendframework/zendservice-amazon: affected < 2.0.3; fixed in 2.0.3
- Packagist zendframework/zendservice-api: affected < 1.0.0; fixed in 1.0.0
- Packagist zendframework/zendservice-technorati: affected < 2.0.2; fixed in 2.0.2
- Packagist zendframework/zendrest: affected < 2.0.2; fixed in 2.0.2
- Packagist zendframework/zendservice-windowsazure: affected < 2.0.2; fixed in 2.0.2
- Packagist zendframework/zendservice-slideshare: affected < 2.0.2; fixed in 2.0.2
- Packagist zendframework/zendservice-audioscrobbler: affected < 2.0.2; fixed in 2.0.2
- Packagist zendframework/zendframework1: affected < 1.12.4; fixed in 1.12.4
- Packagist zendframework/zendservice-nirvanix: affected < 2.0.2; fixed in 2.0.2
- Packagist zendframework/zendopenid: affected < 2.0.2; fixed in 2.0.2

## Suggested inspection (read-only)
- Packagist zendframework/zendservice-amazon: check the installed version with your package manager.
- Packagist zendframework/zendservice-api: check the installed version with your package manager.
- Packagist zendframework/zendservice-technorati: check the installed version with your package manager.
- Packagist zendframework/zendrest: check the installed version with your package manager.
- Packagist zendframework/zendservice-windowsazure: check the installed version with your package manager.
- Packagist zendframework/zendservice-slideshare: check the installed version with your package manager.
- Packagist zendframework/zendservice-audioscrobbler: check the installed version with your package manager.
- Packagist zendframework/zendframework1: check the installed version with your package manager.
- Packagist zendframework/zendservice-nirvanix: check the installed version with your package manager.
- Packagist zendframework/zendopenid: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on zendframework/zendservice-amazon, zendframework/zendservice-api, zendframework/zendservice-technorati, zendframework/zendrest, zendframework/zendservice-windowsazure, zendframework/zendservice-slideshare, zendframework/zendservice-audioscrobbler, zendframework/zendframework1, zendframework/zendservice-nirvanix, zendframework/zendopenid.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-5wm2-38q5-5rxv (GitHub-reviewed advisory GHSA-5wm2-38q5-5rxv lists affected ranges: Packagist zendframework/zendframework1 >=0 =0 =0 =0 =0 =0 =0 <2.0.2; Packagist zendframework/zendservice-windowsazure…)

Commands are suggestions: review each one before running it.

Loading voting…