ZendXml and Zend Framework contain XXE and XEE Vulnerabilities
CVE-2015-5161GHSA-xp8p-9rq5-4wgv
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (zendframework/zendxml 1.0.1; zendframework/zendframework 2.5.2, 2.4.6, 1.12.14; zendframework/zendframework1 1.12.14), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist zendframework/zendxml
- Affected
- >= 1.0.0, < 1.0.1
- Fixed in
- 1.0.1
Packagist zendframework/zendframework
- Affected
- >= 2.0.0, < 2.4.6>= 2.5.0, < 2.5.2>= 1.12.0, < 1.12.14
- Fixed in
- 1.12.14, 2.5.2, 2.4.6
Packagist zendframework/zendframework1
- Affected
- >= 1.12.0, < 1.12.14
- Fixed in
- 1.12.14
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-xp8p-9rq5-4wgv lists affected ranges: Packagist zendframework/zendframework >=2.0.0 =2.5.0 =1.12.0 =1.12.0 =1.0.0 <1.0.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- CVE-2015-5161: 9.87% estimated exploitation activity in the next 30 days; percentile 95.57 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The ZendXmlSecurity::scan in ZendXml before 1.0.1 and Zend Framework before 1.12.14, 2.x before 2.4.6, and 2.5.x before 2.5.2, when running under PHP-FPM in a threaded environment, allows remote attackers to bypass security checks and conduct XML external entity (XXE) and XML entity expansion (XEE) attacks via multibyte encoded characters.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-xp8p-9rq5-4wgv
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2015-5161 Advisory: ZendXml and Zend Framework contain XXE and XEE Vulnerabilities IDs: CVE-2015-5161, GHSA-xp8p-9rq5-4wgv Record: https://patchnext.com/advisories/cve-2015-5161 (revision 1, source checked 26 Oct 2026, 14:16 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: zendframework/zendxml 1.0.1; zendframework/zendframework 2.5.2, 2.4.6, 1.12.14; zendframework/zendframework1 1.12.14. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist zendframework/zendxml: affected >= 1.0.0, < 1.0.1; fixed in 1.0.1 - Packagist zendframework/zendframework: affected >= 2.0.0, < 2.4.6; >= 2.5.0, < 2.5.2; >= 1.12.0, < 1.12.14; fixed in 1.12.14, 2.5.2, 2.4.6 - Packagist zendframework/zendframework1: affected >= 1.12.0, < 1.12.14; fixed in 1.12.14 ## Suggested inspection (read-only) - Packagist zendframework/zendxml: check the installed version with your package manager. - Packagist zendframework/zendframework: check the installed version with your package manager. - Packagist zendframework/zendframework1: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on zendframework/zendxml, zendframework/zendframework, zendframework/zendframework1. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-xp8p-9rq5-4wgv (GitHub-reviewed advisory GHSA-xp8p-9rq5-4wgv lists affected ranges: Packagist zendframework/zendframework >=2.0.0 =2.5.0 =1.12.0 =1.12.0 =1.0.0 <1.0.1) Commands are suggestions: review each one before running it.
Loading voting…