Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.
Open advisories
12 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.
In MODX Revolution before 2.5.7, an attacker might be able to trigger XSS by injecting a payload into the HTTP Host header of a request. This is exploitable only in conjunction with other issues such as Cache Poisoning.
Recommended action: Upgrade to 2.5.7 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.
In MODX Revolution before 2.5.7, a user with resource edit permissions can inject an XSS payload into the title of any post via the pagetitle parameter to connectors/index.php.
Recommended action: Upgrade to 2.5.7 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.
In MODX Revolution before 2.5.7, a user with file upload permissions is able to execute arbitrary code by uploading a file with the name .htaccess.
Recommended action: Upgrade to 2.5.7 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.
In MODX Revolution before 2.5.7, an attacker is able to trigger Reflected XSS by injecting payloads into several fields on the setup page, as demonstrated by the databasetype parameter.
Recommended action: Upgrade to 2.5.7 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.
In MODX Revolution before 2.5.7, when PHP 5.3.3 is used, an attacker is able to include and execute arbitrary files on the web server due to insufficient validation of the action parameter to setup/index.php, aka directory traversal.
Recommended action: Upgrade to 2.5.7 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.
MODX Revolution version 2.x - 2.5.6 is vulnerable to blind SQL injection caused by improper sanitization by the escape method resulting in authenticated user accessing database and possibly escalating privileges.
Recommended action: Upgrade to 2.6.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.
MODX Revolution through v2.7.0-pl allows XSS via the User Photo field.
Recommended action: Upgrade to 2.7.1-pl (pre-release) or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.
MODX Revolution through v2.7.0-pl allows XSS via an extended user field such as a Container name or Attribute name.
Recommended action: Upgrade to 2.7.1-pl (pre-release) or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.
MODX Revolution through v2.7.0-pl allows XSS via a document resource (such as pagetitle), which is mishandled during an Update action, a Quick Edit action, or the viewing of manager logs.
Recommended action: Upgrade to 2.7.1-pl (pre-release) or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.
MODX Revolution version <=2.6.4 contains a Incorrect Access Control vulnerability in Filtering user parameters before passing them into phpthumb class that can result in Creating file with custom a filename and content. This attack appear to be exploitable via Web request. This vulnerability appears to have been fixed in commit 06bc94257408f6a575de20ddb955aca505ef6e68.
Recommended action: Upgrade to 2.7.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.
MODX Revolution through v2.7.0-pl allows XSS via User Settings such as Description.
Recommended action: Upgrade to 2.7.1-pl (pre-release) or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.
A XML External Entity (XXE) vulnerability was discovered in the modRestServiceRequest component in MODX CMS 2.7.3 which can lead to an information disclosure or denial of service (DOS).
Recommended action: Upgrade to 2.8.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.