MODX Revolution XSS via HTTP Host header
CVE-2017-9071GHSA-p2j4-vrgx-96qg
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (modx/revolution 2.5.7), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist modx/revolution
- Affected
- < 2.5.7
- Fixed in
- 2.5.7
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-p2j4-vrgx-96qg lists affected ranges: Packagist modx/revolution >=0 <2.5.7
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.7 · CVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2017-9071: 0.65% estimated exploitation activity in the next 30 days; percentile 51.13 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
In MODX Revolution before 2.5.7, an attacker might be able to trigger XSS by injecting a payload into the HTTP Host header of a request. This is exploitable only in conjunction with other issues such as Cache Poisoning.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-p2j4-vrgx-96qg
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2017-9071 Advisory: MODX Revolution XSS via HTTP Host header IDs: CVE-2017-9071, GHSA-p2j4-vrgx-96qg Record: https://patchnext.com/advisories/cve-2017-9071 (revision 1, source checked 26 Oct 2026, 14:30 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: modx/revolution 2.5.7. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist modx/revolution: affected < 2.5.7; fixed in 2.5.7 ## Suggested inspection (read-only) - Packagist modx/revolution: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on modx/revolution. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-p2j4-vrgx-96qg (GitHub-reviewed advisory GHSA-p2j4-vrgx-96qg lists affected ranges: Packagist modx/revolution >=0 <2.5.7) Commands are suggestions: review each one before running it.
Loading voting…