MODX Revolution allows overwriting .htaccess
CVE-2017-9069GHSA-23gj-x27g-r34f
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (modx/revolution 2.5.7), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist modx/revolution
- Affected
- < 2.5.7
- Fixed in
- 2.5.7
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-23gj-x27g-r34f lists affected ranges: Packagist modx/revolution >=0 <2.5.7
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.8 · CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2017-9069: 1.86% estimated exploitation activity in the next 30 days; percentile 79.31 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
In MODX Revolution before 2.5.7, a user with file upload permissions is able to execute arbitrary code by uploading a file with the name .htaccess.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-23gj-x27g-r34f
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2017-9069 Advisory: MODX Revolution allows overwriting .htaccess IDs: CVE-2017-9069, GHSA-23gj-x27g-r34f Record: https://patchnext.com/advisories/cve-2017-9069 (revision 1, source checked 26 Oct 2026, 14:30 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: modx/revolution 2.5.7. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist modx/revolution: affected < 2.5.7; fixed in 2.5.7 ## Suggested inspection (read-only) - Packagist modx/revolution: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on modx/revolution. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-23gj-x27g-r34f (GitHub-reviewed advisory GHSA-23gj-x27g-r34f lists affected ranges: Packagist modx/revolution >=0 <2.5.7) Commands are suggestions: review each one before running it.
Loading voting…