MODX Revolution Incorrect Access Control vulnerability
CVE-2018-1000207GHSA-m899-6mh4-mpc5
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (modx/revolution 2.7.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist modx/revolution
- Affected
- <= 2.6.4
- Fixed in
- 2.7.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-m899-6mh4-mpc5 lists affected ranges: Packagist modx/revolution >=0 <=2.6.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.2 · CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2018-1000207: 64.09% estimated exploitation activity in the next 30 days; percentile 99.23 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
MODX Revolution version <=2.6.4 contains a Incorrect Access Control vulnerability in Filtering user parameters before passing them into phpthumb class that can result in Creating file with custom a filename and content. This attack appear to be exploitable via Web request. This vulnerability appears to have been fixed in commit 06bc94257408f6a575de20ddb955aca505ef6e68.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-m899-6mh4-mpc5
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2018-1000207 Advisory: MODX Revolution Incorrect Access Control vulnerability IDs: CVE-2018-1000207, GHSA-m899-6mh4-mpc5 Record: https://patchnext.com/advisories/cve-2018-1000207 (revision 1, source checked 26 Oct 2026, 14:09 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: modx/revolution 2.7.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist modx/revolution: affected <= 2.6.4; fixed in 2.7.0 ## Suggested inspection (read-only) - Packagist modx/revolution: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on modx/revolution. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-m899-6mh4-mpc5 (GitHub-reviewed advisory GHSA-m899-6mh4-mpc5 lists affected ranges: Packagist modx/revolution >=0 <=2.6.4) Commands are suggestions: review each one before running it.
Loading voting…