Skip to content

← Public intelligence

Packagist package

genix/cms

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

9 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 7.3PackagistPublished

    GeniXCMS SQL injection vulnerability

    CVE-2016-10096 · GHSA-gjcj-fj23-5j5v

    Affected
    • Packagist genix/cms < 1.0.0
    Fixed in
    1.0.0· Vendor fix available
    Issue
    SQL injection vulnerability in register.php in GeniXCMS before 1.0.0 allows remote attackers to execute arbitrary SQL commands via the activation parameter.

    Recommended action: Upgrade to 1.0.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Medium, CVSS 5.4PackagistPublished

    GeniXCMS Cross-site Scripting (XSS)

    CVE-2017-8376 · GHSA-52xr-wx26-9rfg

    Affected
    • Packagist genix/cms < 1.1.0
    Fixed in
    1.1.0· Vendor fix available
    Issue
    GeniXCMS 1.0.2 has XSS triggered by an authenticated comment that is mishandled during a mouse operation by an administrator.

    Recommended action: Upgrade to 1.1.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. High, CVSS 8.8PackagistPublished

    GeniXCMS SQL Injection

    CVE-2017-8377 · GHSA-34vw-8cjw-cwjj

    Affected
    • Packagist genix/cms < 1.1.0
    Fixed in
    1.1.0· Vendor fix available
    Issue
    GeniXCMS 1.0.2 has SQL Injection in inc/lib/Control/Backend/menus.control.php via the menuid parameter.

    Recommended action: Upgrade to 1.1.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  4. Medium, CVSS 5.4PackagistPublished

    GeniXCMS Cross-site Scripting (XSS)

    CVE-2017-8762 · GHSA-4399-46r4-5rmv

    Affected
    • Packagist genix/cms < 1.1.1
    Fixed in
    1.1.1· Vendor fix available
    Issue
    GeniXCMS 1.0.2 has XSS triggered by an authenticated user who submits a page, as demonstrated by a crafted oncut attribute in a B element.

    Recommended action: Upgrade to 1.1.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  5. Medium, CVSS 4.8PackagistPublished

    GeniXCMS Cross-site Scripting

    CVE-2017-8780 · GHSA-5hf2-7xf4-w3j6

    Affected
    • Packagist genix/cms < 1.1.0
    Fixed in
    1.1.0· Vendor fix available
    Issue
    GeniXCMS 1.0.2 has XSS triggered by a comment that is mishandled during a publish operation by an administrator, as demonstrated by a malformed P element.

    Recommended action: Upgrade to 1.1.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  6. Critical, CVSS 9.1PackagistPublished

    GeniXCMS Arbitrary User Password Reset Vulnerability

    CVE-2017-8827 · GHSA-wm7g-rmgg-9837

    Affected
    • Packagist genix/cms < 1.1.2
    Fixed in
    1.1.2· Vendor fix available
    Issue
    forgotpassword.php in GeniXCMS lacks a rate limit, which might allow remote attackers to cause a denial of service (login inability) or possibly conduct Arbitrary User Password Reset attacks via a series of requests.

    Recommended action: Upgrade to 1.1.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  7. Medium, CVSS 5.3PackagistPublished

    GeniXCMS denial of service (account blockage)

    CVE-2017-14231 · GHSA-2m9r-pm7q-wr6f

    Affected
    • Packagist genix/cms < 1.1.0
    Fixed in
    1.1.0· Vendor fix available
    Issue
    GeniXCMS before 1.1.0 allows remote attackers to cause a denial of service (account blockage) by leveraging the mishandling of certain username substring relationships, such as the admin<script username versus the admin username, related to register.php, User.class.php, and Type.class.php.

    Recommended action: Upgrade to 1.1.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  8. High, CVSS 7.2PackagistPublished

    GeniXCMS SQL injection vulnerability

    CVE-2017-5346 · GHSA-2ppw-6xvg-rwgw

    Affected
    • Packagist genix/cms < 1.0.0
    Fixed in
    1.0.0· Vendor fix available
    Issue
    SQL injection vulnerability in inc/lib/Control/Backend/posts.control.php in GeniXCMS 0.0.8 allows remote authenticated administrators to execute arbitrary SQL commands via the id parameter to gxadmin/index.php.

    Recommended action: Upgrade to 1.0.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  9. Medium, CVSS 5.3PackagistPublished

    GeniXCMS Mailbox validation logic vulnerability

    CVE-2017-8388 · GHSA-559c-w54x-8342

    Affected
    • Packagist genix/cms < 1.1.0
    Fixed in
    1.1.0· Vendor fix available
    Issue
    GeniXCMS 1.0.2 allows remote attackers to bypass the alertDanger MSGUSEREMAILEXIST protection mechanism via a register.php?act=edit&id=1 request.

    Recommended action: Upgrade to 1.1.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →