GeniXCMS Cross-site Scripting
CVE-2017-8780GHSA-5hf2-7xf4-w3j6
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (genix/cms 1.1.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist genix/cms
- Affected
- < 1.1.0
- Fixed in
- 1.1.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-5hf2-7xf4-w3j6 lists affected ranges: Packagist genix/cms >=0 <1.1.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.8 · CVSS:3.0/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2017-8780: 0.60% estimated exploitation activity in the next 30 days; percentile 48.68 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
GeniXCMS 1.0.2 has XSS triggered by a comment that is mishandled during a publish operation by an administrator, as demonstrated by a malformed P element.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-5hf2-7xf4-w3j6
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2017-8780 Advisory: GeniXCMS Cross-site Scripting IDs: CVE-2017-8780, GHSA-5hf2-7xf4-w3j6 Record: https://patchnext.com/advisories/cve-2017-8780 (revision 1, source checked 26 Oct 2026, 14:20 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: genix/cms 1.1.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist genix/cms: affected < 1.1.0; fixed in 1.1.0 ## Suggested inspection (read-only) - Packagist genix/cms: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on genix/cms. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-5hf2-7xf4-w3j6 (GitHub-reviewed advisory GHSA-5hf2-7xf4-w3j6 lists affected ranges: Packagist genix/cms >=0 <1.1.0) Commands are suggestions: review each one before running it.
Loading voting…