Skip to content

← Actionable
Medium, CVSS 5.3

GeniXCMS denial of service (account blockage)

CVE-2017-14231GHSA-2m9r-pm7q-wr6f

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (genix/cms 1.1.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist genix/cms

    Affected
    < 1.1.0
    Fixed in
    1.1.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.3 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
EPSS
  • CVE-2017-14231: 1.42% estimated exploitation activity in the next 30 days; percentile 72.87 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

GeniXCMS before 1.1.0 allows remote attackers to cause a denial of service (account blockage) by leveraging the mishandling of certain username substring relationships, such as the admin<script username versus the admin username, related to register.php, User.class.php, and Type.class.php.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-2m9r-pm7q-wr6f

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2017-14231

Advisory: GeniXCMS denial of service (account blockage)
IDs: CVE-2017-14231, GHSA-2m9r-pm7q-wr6f
Record: https://patchnext.com/advisories/cve-2017-14231 (revision 1, source checked 26 Oct 2026, 14:20 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: genix/cms 1.1.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist genix/cms: affected < 1.1.0; fixed in 1.1.0

## Suggested inspection (read-only)
- Packagist genix/cms: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on genix/cms.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-2m9r-pm7q-wr6f (GitHub-reviewed advisory GHSA-2m9r-pm7q-wr6f lists affected ranges: Packagist genix/cms >=0 <1.1.0)

Commands are suggestions: review each one before running it.

Loading voting…