Skip to content

← Actionable
Critical, CVSS 9.1

GeniXCMS Arbitrary User Password Reset Vulnerability

CVE-2017-8827GHSA-wm7g-rmgg-9837

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (genix/cms 1.1.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist genix/cms

    Affected
    < 1.1.2
    Fixed in
    1.1.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.1 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:H
EPSS
  • CVE-2017-8827: 1.62% estimated exploitation activity in the next 30 days; percentile 76.08 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

forgotpassword.php in GeniXCMS lacks a rate limit, which might allow remote attackers to cause a denial of service (login inability) or possibly conduct Arbitrary User Password Reset attacks via a series of requests.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-wm7g-rmgg-9837

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2017-8827

Advisory: GeniXCMS Arbitrary User Password Reset Vulnerability
IDs: CVE-2017-8827, GHSA-wm7g-rmgg-9837
Record: https://patchnext.com/advisories/cve-2017-8827 (revision 1, source checked 26 Oct 2026, 14:20 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: genix/cms 1.1.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist genix/cms: affected < 1.1.2; fixed in 1.1.2

## Suggested inspection (read-only)
- Packagist genix/cms: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on genix/cms.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-wm7g-rmgg-9837 (GitHub-reviewed advisory GHSA-wm7g-rmgg-9837 lists affected ranges: Packagist genix/cms >=0 <1.1.2)

Commands are suggestions: review each one before running it.

Loading voting…