Skip to content

← Public intelligence

Packagist package

cakephp/database

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

3 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Critical, CVSS 9.2PackagistAmendedPublished

    CakePHP: Multiple methods in FunctionsBuilder vulnerable to SQL injection

    CVE-2026-79752 · GHSA-vjqc-q4mp-2rvf

    Affected
    • Packagist cakephp/database >= 4.6.0, < 4.6.5; >= 5.0.0, < 5.1.9; >= 5.2.0, < 5.2.14; >= 5.3.0, < 5.3.7; >= 3.0.0, < 4.5.12
    Fixed in
    5.2.145.1.94.5.125.3.74.6.5· Vendor fix available
    Issue
    Impact The FunctionsBuilder::cast($field, $dataType), extract($part, $expr), datePart($part, $expr), dateAdd($expr, $value, $unit) methods are vulnerable to SQL injection if user controlled data is supplied to the ($dataType / $part / $unit) parameters. Patches 5.3.7, 5.2.14, 5.1.9, 4.6.5, 4.5.12 contain fixes Workarounds Don't provide user controlled data to these functions/parameters.

    Recommended action: Upgrade to 5.3.7, 5.2.14, 5.1.9 or 2 more by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. Critical, CVSS 9.2PackagistAmendedPublished

    CakePHP: FunctionsBuilder::jsonValue() vulerable to SQL injection with PostgresDriver

    CVE-2026-77635 · GHSA-fxf7-vhh8-7vpq

    Affected
    • Packagist cakephp/database >= 5.3.0, < 5.3.7; >= 5.2.0, < 5.2.15; >= 5.1.0, < 5.1.10
    Fixed in
    5.2.155.1.105.3.7· Vendor fix available
    Issue
    Impact The FunctionsBuilder::jsonValue($field, $jsonPath) methods with the Postgres driver is vulnerable to SQL injection if user controlled data is supplied to the $jsonPath parameter. Patches 5.1.10, 5.2.15, 5.3.7 Workarounds Don't provide user controlled data to these functions/parameters.

    Recommended action: Upgrade to 5.3.7, 5.2.15 or 5.1.10 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  3. Critical, CVSS 9.8PackagistPublished

    CakePHP Database\\Query::offset() and limit() methods are vulnerable to SQL injection

    CVE-2023-22727 · GHSA-6g8q-qfpv-57wp

    Affected
    • Packagist cakephp/database >= 4.2.0, < 4.2.12; >= 4.3.0, < 4.3.11; >= 4.4.0, < 4.4.10
    Fixed in
    4.4.104.3.114.2.12· Vendor fix available
    Issue
    Impact The Cake\Database\Query::limit() and Cake\Database\Query::offset() methods are vulnerable to SQL injection if passed un-sanitized user request data. Patches This issue has been fixed in 4.2.12, 4.3.11, 4.4.10 Workarounds Using CakePHP's Pagination library will mitigate this issue, as will validating or casting parameters to these methods. References https://bakery.cakephp.org/2023/01/06/cakephp421143114410released.html

    Recommended action: Upgrade to 4.4.10, 4.3.11 or 4.2.12 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →