Skip to content

← Actionable
Critical, CVSS 9.2amended

CakePHP: FunctionsBuilder::jsonValue() vulerable to SQL injection with PostgresDriver

CVE-2026-77635GHSA-fxf7-vhh8-7vpq

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (cakephp/database 5.3.7, 5.2.15, 5.1.10; cakephp/cakephp 5.3.7, 5.2.15, 5.1.10), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist cakephp/database

    Affected
    >= 5.3.0, < 5.3.7>= 5.2.0, < 5.2.15>= 5.1.0, < 5.1.10
    Fixed in
    5.2.15, 5.1.10, 5.3.7
  • Packagist cakephp/cakephp

    Affected
    >= 5.3.0, < 5.3.7>= 5.2.0, < 5.2.15>= 5.1.0, < 5.1.10
    Fixed in
    5.2.15, 5.1.10, 5.3.7

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
9.2 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:L/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X · score source
EPSS
  • CVE-2026-77635: 0.49% estimated exploitation activity in the next 30 days; percentile 42.38 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact The FunctionsBuilder::jsonValue($field, $jsonPath) methods with the Postgres driver is vulnerable to SQL injection if user controlled data is supplied to the $jsonPath parameter. Patches 5.1.10, 5.2.15, 5.3.7 Workarounds Don't provide user controlled data to these functions/parameters.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-fxf7-vhh8-7vpq

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-fxf7-vhh8-7vpq

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-77635

Advisory: CakePHP: FunctionsBuilder::jsonValue() vulerable to SQL injection with PostgresDriver
IDs: CVE-2026-77635, GHSA-fxf7-vhh8-7vpq
Record: https://patchnext.com/advisories/cve-2026-77635 (revision 3, source checked 26 Oct 2026, 14:53 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: cakephp/database 5.3.7, 5.2.15, 5.1.10; cakephp/cakephp 5.3.7, 5.2.15, 5.1.10. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist cakephp/database: affected >= 5.3.0, < 5.3.7; >= 5.2.0, < 5.2.15; >= 5.1.0, < 5.1.10; fixed in 5.2.15, 5.1.10, 5.3.7
- Packagist cakephp/cakephp: affected >= 5.3.0, < 5.3.7; >= 5.2.0, < 5.2.15; >= 5.1.0, < 5.1.10; fixed in 5.2.15, 5.1.10, 5.3.7

## Suggested inspection (read-only)
- Packagist cakephp/database: check the installed version with your package manager.
- Packagist cakephp/cakephp: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on cakephp/database, cakephp/cakephp.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-fxf7-vhh8-7vpq (OSV record GHSA-fxf7-vhh8-7vpq lists affected ranges: Packagist cakephp/cakephp >=5.3.0 =5.2.0 =5.1.0 =5.3.0 =5.2.0 =5.1.0 <5.1.10 (fixed))
- Verified: https://github.com/advisories/GHSA-fxf7-vhh8-7vpq (GitHub-reviewed advisory GHSA-fxf7-vhh8-7vpq lists affected ranges: Packagist cakephp/cakephp >=5.3.0 =5.2.0 =5.1.0 =5.3.0 =5.2.0 =5.1.0 <5.1.10)

Commands are suggestions: review each one before running it.

Loading voting…