CakePHP: Multiple methods in FunctionsBuilder vulnerable to SQL injection
CVE-2026-79752GHSA-vjqc-q4mp-2rvf
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (cakephp/database 5.3.7, 5.2.14, 5.1.9, 4.6.5, 4.5.12; cakephp/cakephp 5.3.7, 5.2.14, 5.1.9, 4.6.5, 4.5.12), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist cakephp/database
- Affected
- >= 4.6.0, < 4.6.5>= 5.0.0, < 5.1.9>= 5.2.0, < 5.2.14>= 5.3.0, < 5.3.7>= 3.0.0, < 4.5.12
- Fixed in
- 5.2.14, 5.1.9, 4.5.12, 5.3.7, 4.6.5
Packagist cakephp/cakephp
- Affected
- < 4.5.12>= 4.6.0, < 4.6.5>= 5.0.0, < 5.1.9>= 5.2.0, < 5.2.14>= 5.3.0, < 5.3.7
- Fixed in
- 5.2.14, 5.1.9, 4.5.12, 5.3.7, 4.6.5
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-vjqc-q4mp-2rvf lists affected ranges: Packagist cakephp/database >=3.0.0 =4.6.0 =5.0.0 =5.2.0 =5.3.0 =0 =4.6.0 =5.0.0 =5.2.0 =5.3.0 <5.3.7 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-vjqc-q4mp-2rvf lists affected ranges: Packagist cakephp/database >=4.6.0 =5.0.0 =5.2.0 =5.3.0 =3.0.0 =0 =4.6.0 =5.0.0 =5.2.0 =5.3.0 <5.3.7
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 9.2 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-79752: 0.62% estimated exploitation activity in the next 30 days; percentile 49.81 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact The FunctionsBuilder::cast($field, $dataType), extract($part, $expr), datePart($part, $expr), dateAdd($expr, $value, $unit) methods are vulnerable to SQL injection if user controlled data is supplied to the ($dataType / $part / $unit) parameters. Patches 5.3.7, 5.2.14, 5.1.9, 4.6.5, 4.5.12 contain fixes Workarounds Don't provide user controlled data to these functions/parameters.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-vjqc-q4mp-2rvf
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-vjqc-q4mp-2rvf
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-79752 Advisory: CakePHP: Multiple methods in FunctionsBuilder vulnerable to SQL injection IDs: CVE-2026-79752, GHSA-vjqc-q4mp-2rvf Record: https://patchnext.com/advisories/cve-2026-79752 (revision 3, source checked 26 Oct 2026, 14:53 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: cakephp/database 5.3.7, 5.2.14, 5.1.9, 4.6.5, 4.5.12; cakephp/cakephp 5.3.7, 5.2.14, 5.1.9, 4.6.5, 4.5.12. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist cakephp/database: affected >= 4.6.0, < 4.6.5; >= 5.0.0, < 5.1.9; >= 5.2.0, < 5.2.14; >= 5.3.0, < 5.3.7; >= 3.0.0, < 4.5.12; fixed in 5.2.14, 5.1.9, 4.5.12, 5.3.7, 4.6.5 - Packagist cakephp/cakephp: affected < 4.5.12; >= 4.6.0, < 4.6.5; >= 5.0.0, < 5.1.9; >= 5.2.0, < 5.2.14; >= 5.3.0, < 5.3.7; fixed in 5.2.14, 5.1.9, 4.5.12, 5.3.7, 4.6.5 ## Suggested inspection (read-only) - Packagist cakephp/database: check the installed version with your package manager. - Packagist cakephp/cakephp: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on cakephp/database, cakephp/cakephp. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-vjqc-q4mp-2rvf (OSV record GHSA-vjqc-q4mp-2rvf lists affected ranges: Packagist cakephp/database >=3.0.0 =4.6.0 =5.0.0 =5.2.0 =5.3.0 =0 =4.6.0 =5.0.0 =5.2.0 =5.3.0 <5.3.7 (fixed)) - Verified: https://github.com/advisories/GHSA-vjqc-q4mp-2rvf (GitHub-reviewed advisory GHSA-vjqc-q4mp-2rvf lists affected ranges: Packagist cakephp/database >=4.6.0 =5.0.0 =5.2.0 =5.3.0 =3.0.0 =0 =4.6.0 =5.0.0 =5.2.0 =5.3.0 <5.3.7) Commands are suggestions: review each one before running it.
Loading voting…