Skip to content

← Actionable
Critical, CVSS 9.8

CakePHP Database\\Query::offset() and limit() methods are vulnerable to SQL injection

CVE-2023-22727GHSA-6g8q-qfpv-57wp

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (cakephp/database 4.4.10, 4.3.11, 4.2.12; cakephp/cakephp 4.4.10, 4.3.11, 4.2.12), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist cakephp/database

    Affected
    >= 4.2.0, < 4.2.12>= 4.3.0, < 4.3.11>= 4.4.0, < 4.4.10
    Fixed in
    4.4.10, 4.3.11, 4.2.12
  • Packagist cakephp/cakephp

    Affected
    >= 4.2.0, < 4.2.12>= 4.3.0, < 4.3.11>= 4.4.0, < 4.4.10
    Fixed in
    4.4.10, 4.3.11, 4.2.12

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2023-22727: 0.90% estimated exploitation activity in the next 30 days; percentile 59.65 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact The Cake\Database\Query::limit() and Cake\Database\Query::offset() methods are vulnerable to SQL injection if passed un-sanitized user request data. Patches This issue has been fixed in 4.2.12, 4.3.11, 4.4.10 Workarounds Using CakePHP's Pagination library will mitigate this issue, as will validating or casting parameters to these methods. References https://bakery.cakephp.org/2023/01/06/cakephp421143114410released.html

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-6g8q-qfpv-57wp

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-22727

Advisory: CakePHP Database\\Query::offset() and limit() methods are vulnerable to SQL injection
IDs: CVE-2023-22727, GHSA-6g8q-qfpv-57wp
Record: https://patchnext.com/advisories/cve-2023-22727 (revision 1, source checked 26 Oct 2026, 13:56 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: cakephp/database 4.4.10, 4.3.11, 4.2.12; cakephp/cakephp 4.4.10, 4.3.11, 4.2.12. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist cakephp/database: affected >= 4.2.0, < 4.2.12; >= 4.3.0, < 4.3.11; >= 4.4.0, < 4.4.10; fixed in 4.4.10, 4.3.11, 4.2.12
- Packagist cakephp/cakephp: affected >= 4.2.0, < 4.2.12; >= 4.3.0, < 4.3.11; >= 4.4.0, < 4.4.10; fixed in 4.4.10, 4.3.11, 4.2.12

## Suggested inspection (read-only)
- Packagist cakephp/database: check the installed version with your package manager.
- Packagist cakephp/cakephp: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on cakephp/database, cakephp/cakephp.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-6g8q-qfpv-57wp (GitHub-reviewed advisory GHSA-6g8q-qfpv-57wp lists affected ranges: Packagist cakephp/cakephp >=4.2.0 =4.3.0 =4.4.0 =4.2.0 =4.3.0 =4.4.0 <4.4.10)

Commands are suggestions: review each one before running it.

Loading voting…