Skip to content

← Public intelligence

Maven package

org.apache.thrift:libthrift

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

7 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 8.7MavenAmendedPublished

    Apache Thrift Python, Go, PHP and Java bindings have an Infinite Loop

    CVE-2026-43871 · GHSA-8wv5-x4w7-5gww

    Affected
    • Maven org.apache.thrift:libthrift < 0.24.0
    Fixed in
    0.24.0· Vendor fix available
    Issue
    Loop with Unreachable Exit Condition ('Infinite Loop') vulnerability in Apache Thrift Python, Go, PHP and Java bindings.This issue affects Apache Thrift: before 0.24.0. Users are recommended to upgrade to version 0.24.0, which fixes the issue.

    Recommended action: Upgrade to 0.24.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. High, CVSS 7.3MavenPublished

    Apache Thrift has an Improper Validation of Certificate with Host Mismatch Vulnerability

    CVE-2026-43869 · GHSA-7pwc-h2j2-rjgj

    Affected
    • Maven org.apache.thrift:libthrift <= 0.22.0
    Fixed in
    0.23.0· Vendor fix available
    Issue
    Improper Validation of Certificate with Host Mismatch vulnerability in Apache Thrift. This issue affects Apache Thrift: before 0.23.0. Users are recommended to upgrade to version 0.23.0, which fixes the issue.

    Recommended action: Upgrade to 0.23.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. High, CVSS 7.4MavenAmendedPublished

    Apache Thrift has an issue with Java TSSLTransportFactory hostname verification

    CVE-2026-41603 · GHSA-gf47-qgg5-9g9q

    Affected
    • Maven org.apache.thrift:libthrift < 0.23.0
    Fixed in
    0.23.0· Vendor fix available
    Issue
    Improper Validation of Certificate with Host Mismatch vulnerability in Apache Thrift. This issue affects Apache Thrift: before 0.23.0. Users are recommended to upgrade to version 0.23.0, which fixes the issue.

    Recommended action: Upgrade to 0.23.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.com (1)osv.dev (2)osv.dev (3)Source checked Evidence →
  4. High, CVSS 7.5MavenPublished

    Loop with Unreachable Exit Condition in Apache Thrift

    CVE-2019-0205 · GHSA-rj7p-rfgp-852x

    Affected
    • Maven org.apache.thrift:libthrift <= 0.12.0
    Fixed in
    0.13.0· Vendor fix available
    Issue
    In Apache Thrift all versions up to and including 0.12.0, a server or client may run into an endless loop when feed with specific input data. Because the issue had already been partially fixed in version 0.11.0, depending on the installed version it affects only certain language bindings.

    Recommended action: Upgrade to 0.13.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  5. High, CVSS 7.5MavenPublished

    Uncontrolled Resource Consumption in Apache Thrift

    CVE-2020-13949 · GHSA-g2fg-mr77-6vrm

    Affected
    • Maven org.apache.thrift:libthrift >= 0.9.3, < 0.14.0
    Fixed in
    0.14.0· Vendor fix available
    Issue
    In Apache Thrift 0.9.3 to 0.13.0, malicious RPC clients could send short messages which would result in a large memory allocation, potentially leading to denial of service.

    Recommended action: Upgrade to 0.14.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  6. High, CVSS 7.5MavenPublished

    Improper Input Validation in Apache Thrift

    CVE-2018-1320 · GHSA-wjxj-f8rg-99wx

    Affected
    • Maven org.apache.thrift:libthrift >= 0.5.0, < 0.9.3-1; >= 0.10.0, < 0.12.0
    Fixed in
    0.9.3-10.12.0· Vendor fix available
    Issue
    Apache Thrift Java client library versions 0.5.0 prior to 0.9.3-1 and 0.10.0 prior to 0.12.0 can bypass SASL negotiation isComplete validation in the org.apache.thrift.transport.TSaslTransport class. An assert used to determine if the SASL handshake had successfully completed could be disabled in production settings making the validation incomplete.

    Recommended action: Upgrade to 0.12.0 or 0.9.3-1 (pre-release) by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  7. Medium, CVSS 6.5MavenPublished

    Apache Thrift Node.js static web server sandbox escape

    CVE-2018-11798 · GHSA-vx85-mj8c-4qm6

    Affected
    • Maven org.apache.thrift:libthrift >= 0.9.2, < 0.12.0
    Fixed in
    0.12.0· Vendor fix available
    Issue
    The Apache Thrift Node.js static web server in versions 0.9.2 through 0.11.0 have been determined to contain a security vulnerability in which a remote user has the ability to access files outside the set webservers docroot path.

    Recommended action: Upgrade to 0.12.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →