Apache Thrift Python, Go, PHP and Java bindings have an Infinite Loop
CVE-2026-43871GHSA-8wv5-x4w7-5gww
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (thrift 0.24.0; github.com/apache/thrift 0.24.0; apache/thrift 0.24.0; org.apache.thrift:libthrift 0.24.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI thrift
- Affected
- < 0.24.0
- Fixed in
- 0.24.0
- Affected
- < 0.24.0
- Fixed in
- 0.24.0
Packagist apache/thrift
- Affected
- < 0.24.0
- Fixed in
- 0.24.0
Maven org.apache.thrift:libthrift
- Affected
- < 0.24.0
- Fixed in
- 0.24.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-8wv5-x4w7-5gww lists affected ranges: PyPI thrift >=0 =0 =0 =0 <0.24.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-8wv5-x4w7-5gww lists affected ranges: PyPI thrift >=0 =0 =0 =0 <0.24.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-43871: 1.03% estimated exploitation activity in the next 30 days; percentile 63.75 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Loop with Unreachable Exit Condition ('Infinite Loop') vulnerability in Apache Thrift Python, Go, PHP and Java bindings.This issue affects Apache Thrift: before 0.24.0. Users are recommended to upgrade to version 0.24.0, which fixes the issue.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-8wv5-x4w7-5gww
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-8wv5-x4w7-5gww
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-43871 Advisory: Apache Thrift Python, Go, PHP and Java bindings have an Infinite Loop IDs: CVE-2026-43871, GHSA-8wv5-x4w7-5gww Record: https://patchnext.com/advisories/cve-2026-43871 (revision 3, source checked 26 Oct 2026, 13:51 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: thrift 0.24.0; github.com/apache/thrift 0.24.0; apache/thrift 0.24.0; org.apache.thrift:libthrift 0.24.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI thrift: affected < 0.24.0; fixed in 0.24.0 - Go github.com/apache/thrift: affected < 0.24.0; fixed in 0.24.0 - Packagist apache/thrift: affected < 0.24.0; fixed in 0.24.0 - Maven org.apache.thrift:libthrift: affected < 0.24.0; fixed in 0.24.0 ## Suggested inspection (read-only) - `python -m pip show thrift`: prints the installed version. Run with the environment that serves production active. - Go github.com/apache/thrift: check the installed version with your package manager. - Packagist apache/thrift: check the installed version with your package manager. - Maven org.apache.thrift:libthrift: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on thrift, github.com/apache/thrift, apache/thrift, org.apache.thrift:libthrift. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-8wv5-x4w7-5gww (OSV record GHSA-8wv5-x4w7-5gww lists affected ranges: PyPI thrift >=0 =0 =0 =0 <0.24.0 (fixed)) - Verified: https://github.com/advisories/GHSA-8wv5-x4w7-5gww (GitHub-reviewed advisory GHSA-8wv5-x4w7-5gww lists affected ranges: PyPI thrift >=0 =0 =0 =0 <0.24.0) Commands are suggestions: review each one before running it.
Loading voting…