Skip to content

← Public intelligence

PyPI package

thrift

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

3 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 5.9PyPIPublished

    Apache Thrift Python bindings have a Improper Validation of Certificate with Host Mismatch vulnerabilit

    CVE-2026-66053 · GHSA-hwrj-9rr4-24xh

    Affected
    • PyPI thrift < 0.24.0
    Fixed in
    0.24.0· Vendor fix available
    Issue
    Improper Validation of Certificate with Host Mismatch vulnerability in Apache Thrift Python bindings. This issue affects Apache Thrift: before 0.24.0. Users are recommended to upgrade to version 0.24.0, which fixes the issue. This replaces CVE-2026-41603

    Recommended action: Upgrade to 0.24.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. High, CVSS 7.5PyPIPublished

    Apache Thrift Python bindings have an Improper Handling of Highly Compressed Data (Data Amplification) vulnerability

    CVE-2026-41608 · GHSA-6pjx-3pjc-mrj8

    Affected
    • PyPI thrift < 0.24.0
    Fixed in
    0.24.0· Vendor fix available
    Issue
    Improper Handling of Highly Compressed Data (Data Amplification) vulnerability in Apache Thrift Python bindings. This issue affects Apache Thrift: before 0.24.0. Users are recommended to upgrade to version 0.24.0, which fixes the issue.

    Recommended action: Upgrade to 0.24.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. High, CVSS 8.7PyPIAmendedPublished

    Apache Thrift Python, Go, PHP and Java bindings have an Infinite Loop

    CVE-2026-43871 · GHSA-8wv5-x4w7-5gww

    Affected
    • PyPI thrift < 0.24.0
    Fixed in
    0.24.0· Vendor fix available
    Issue
    Loop with Unreachable Exit Condition ('Infinite Loop') vulnerability in Apache Thrift Python, Go, PHP and Java bindings.This issue affects Apache Thrift: before 0.24.0. Users are recommended to upgrade to version 0.24.0, which fixes the issue.

    Recommended action: Upgrade to 0.24.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →