Apache Thrift Python bindings have an Improper Handling of Highly Compressed Data (Data Amplification) vulnerability
CVE-2026-41608GHSA-6pjx-3pjc-mrj8
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (thrift 0.24.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI thrift
- Affected
- < 0.24.0
- Fixed in
- 0.24.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-6pjx-3pjc-mrj8 lists affected ranges: PyPI thrift >=0 <0.24.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2026-41608: 1.03% estimated exploitation activity in the next 30 days; percentile 63.75 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Improper Handling of Highly Compressed Data (Data Amplification) vulnerability in Apache Thrift Python bindings. This issue affects Apache Thrift: before 0.24.0. Users are recommended to upgrade to version 0.24.0, which fixes the issue.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-6pjx-3pjc-mrj8
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-41608 Advisory: Apache Thrift Python bindings have an Improper Handling of Highly Compressed Data (Data Amplification) vulnerability IDs: CVE-2026-41608, GHSA-6pjx-3pjc-mrj8 Record: https://patchnext.com/advisories/cve-2026-41608 (revision 1, source checked 26 Oct 2026, 13:50 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: thrift 0.24.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI thrift: affected < 0.24.0; fixed in 0.24.0 ## Suggested inspection (read-only) - `python -m pip show thrift`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on thrift. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-6pjx-3pjc-mrj8 (GitHub-reviewed advisory GHSA-6pjx-3pjc-mrj8 lists affected ranges: PyPI thrift >=0 <0.24.0) Commands are suggestions: review each one before running it.
Loading voting…