Apache Thrift has an Improper Validation of Certificate with Host Mismatch Vulnerability
CVE-2026-43869GHSA-7pwc-h2j2-rjgj
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.thrift:libthrift 0.23.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.apache.thrift:libthrift
- Affected
- <= 0.22.0
- Fixed in
- 0.23.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-7pwc-h2j2-rjgj lists affected ranges: Maven org.apache.thrift:libthrift >=0 <=0.22.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
- EPSS
- CVE-2026-43869: 0.63% estimated exploitation activity in the next 30 days; percentile 50.35 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Improper Validation of Certificate with Host Mismatch vulnerability in Apache Thrift. This issue affects Apache Thrift: before 0.23.0. Users are recommended to upgrade to version 0.23.0, which fixes the issue.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-7pwc-h2j2-rjgj
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-43869 Advisory: Apache Thrift has an Improper Validation of Certificate with Host Mismatch Vulnerability IDs: CVE-2026-43869, GHSA-7pwc-h2j2-rjgj Record: https://patchnext.com/advisories/cve-2026-43869 (revision 1, source checked 26 Oct 2026, 16:45 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.apache.thrift:libthrift 0.23.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.apache.thrift:libthrift: affected <= 0.22.0; fixed in 0.23.0 ## Suggested inspection (read-only) - Maven org.apache.thrift:libthrift: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.apache.thrift:libthrift. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-7pwc-h2j2-rjgj (GitHub-reviewed advisory GHSA-7pwc-h2j2-rjgj lists affected ranges: Maven org.apache.thrift:libthrift >=0 <=0.22.0) Commands are suggestions: review each one before running it.
Loading voting…