Apache Thrift has an issue with Java TSSLTransportFactory hostname verification
CVE-2026-41603GHSA-gf47-qgg5-9g9q
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (thrift 0.23.0; org.apache.thrift:libthrift 0.23.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Bitnami thrift
- Affected
- < 0.23.0
- Fixed in
- 0.23.0
Maven org.apache.thrift:libthrift
- Affected
- < 0.23.0
- Fixed in
- 0.23.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-gf47-qgg5-9g9q lists affected ranges: Maven org.apache.thrift:libthrift >=0 <0.23.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-gf47-qgg5-9g9q lists affected ranges: Maven org.apache.thrift:libthrift >=0 <0.23.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record BIT-thrift-2026-41603 lists affected ranges: Bitnami thrift >=0 <0.23.0 (fixed)
VerifiedObserved Structured OSV record; not marked as GitHub-reviewed.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.4 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Improper Validation of Certificate with Host Mismatch vulnerability in Apache Thrift. This issue affects Apache Thrift: before 0.23.0. Users are recommended to upgrade to version 0.23.0, which fixes the issue.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from osv record BIT-thrift-2026-41603
- Revision 2 · amended ·
Amended from osv record GHSA-gf47-qgg5-9g9q
- Revision 1 · created ·
Published from ghsa record GHSA-gf47-qgg5-9g9q
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-41603 Advisory: Apache Thrift has an issue with Java TSSLTransportFactory hostname verification IDs: CVE-2026-41603, GHSA-gf47-qgg5-9g9q Record: https://patchnext.com/advisories/cve-2026-41603 (revision 3, source checked 29 Oct 2026, 06:55 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: thrift 0.23.0; org.apache.thrift:libthrift 0.23.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Bitnami thrift: affected < 0.23.0; fixed in 0.23.0 - Maven org.apache.thrift:libthrift: affected < 0.23.0; fixed in 0.23.0 ## Suggested inspection (read-only) - Bitnami thrift: check the installed version with your package manager. - Maven org.apache.thrift:libthrift: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on thrift, org.apache.thrift:libthrift. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-gf47-qgg5-9g9q (GitHub-reviewed advisory GHSA-gf47-qgg5-9g9q lists affected ranges: Maven org.apache.thrift:libthrift >=0 <0.23.0) - Verified: https://osv.dev/vulnerability/GHSA-gf47-qgg5-9g9q (OSV record GHSA-gf47-qgg5-9g9q lists affected ranges: Maven org.apache.thrift:libthrift >=0 <0.23.0 (fixed)) - Verified: https://osv.dev/vulnerability/BIT-thrift-2026-41603 (OSV record BIT-thrift-2026-41603 lists affected ranges: Bitnami thrift >=0 <0.23.0 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…