Skip to content

← Public intelligence

Maven package

org.apache.struts:struts2-rest-plugin

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

6 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. UnratedMavenPublished

    Code injection in Apache Struts

    CVE-2013-4316 · GHSA-j7h6-xr7g-m2c5

    Affected
    • Maven org.apache.struts:struts2-rest-plugin >= 2.0.0, < 2.3.15.2
    Fixed in
    2.3.15.2· Vendor fix available
    Issue
    Apache Struts 2.0.0 through 2.3.15.1 enables Dynamic Method Invocation by default, which has unknown impact and attack vectors.

    Recommended action: Upgrade to 2.3.15.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Critical, CVSS 9.8MavenPublished

    Arbitrary code execution in Apache Struts 2

    CVE-2016-4438 · GHSA-4prj-vw9j-v6pr

    Affected
    • Maven org.apache.struts:struts2-rest-plugin >= 2.3.19, < 2.3.29
    Fixed in
    2.3.29· Vendor fix available
    Issue
    The REST plugin in Apache Struts 2 2.3.19 through 2.3.28.1 allows remote attackers to execute arbitrary code via a crafted expression.

    Recommended action: Upgrade to 2.3.29 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. High, CVSS 8.1Exploited · CISA KEVMavenPublished

    REST Plugin in Apache Struts uses an XStreamHandler with an instance of XStream for deserialization without any type filtering

    CVE-2017-9805 · GHSA-gg9m-fj3v-r58c

    Affected
    • Maven org.apache.struts:struts2-rest-plugin >= 2.5.0, < 2.5.13; >= 2.1.1, < 2.3.34
    Fixed in
    2.3.342.5.13· Vendor fix available
    Issue
    The REST Plugin in Apache Struts 2.1.1 through 2.3.x before 2.3.34 and 2.5.x before 2.5.13 uses an XStreamHandler with an instance of XStream for deserialization without any type filtering, which can lead to Remote Code Execution when deserializing XML payloads.

    Recommended action: Upgrade to 2.5.13 or 2.3.34 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.com (1)cisa.gov (2)Source checked Evidence →
  4. High, CVSS 7.5MavenPublished

    The REST Plugin in Apache Struts is using an outdated XStream library

    CVE-2017-9793 · GHSA-vwxj-6m5m-rrvh

    Affected
    • Maven org.apache.struts:struts2-rest-plugin >= 2.5.0, <= 2.5.12; < 2.3.34
    Fixed in
    2.3.342.5.13· Vendor fix available
    Issue
    The REST Plugin in Apache Struts 2.3.7 through 2.3.33 and 2.5 through 2.5.12 is using an outdated XStream library which is vulnerable and allow perform a DoS attack using malicious request with specially crafted XML payload.

    Recommended action: Upgrade to 2.5.13 or 2.3.34 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  5. Medium, CVSS 6.2MavenPublished

    Moderate severity vulnerability that affects org.apache.struts:struts2-rest-plugin

    CVE-2017-15707 · GHSA-xcrm-qpp8-hcw4

    Affected
    • Maven org.apache.struts:struts2-rest-plugin >= 2.5.0, <= 2.5.14
    Fixed in
    2.5.16· Vendor fix available
    Issue
    In Apache Struts 2.5 to 2.5.14, the REST Plugin is using an outdated JSON-lib library which is vulnerable and allow perform a DoS attack using malicious request with specially crafted JSON payload.

    Recommended action: Upgrade to 2.5.16 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  6. High, CVSS 7.5MavenPublished

    Apache Struts REST Plugin can potentially allow a DoS attack

    CVE-2018-1327 · GHSA-38cr-2ph5-frr9

    Affected
    • Maven org.apache.struts:struts2-rest-plugin >= 2.1.1, < 2.5.16
    Fixed in
    2.5.16· Vendor fix available
    Issue
    The Apache Struts REST Plugin is using XStream library which is vulnerable and allow perform a DoS attack when using a malicious request with specially crafted XML payload. Upgrade to the Apache Struts version 2.5.16 and switch to an optional Jackson XML handler as described here http://struts.apache.org/plugins/rest/#custom-contenttypehandlers. Another option is to implement a custom XML handler based on the Jackson XML handler from the Apache Struts 2.5.16.

    Recommended action: Upgrade to 2.5.16 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →