Skip to content

← Actionable
High, CVSS 8.1Exploited · CISA KEV

REST Plugin in Apache Struts uses an XStreamHandler with an instance of XStream for deserialization without any type filtering

CVE-2017-9805GHSA-gg9m-fj3v-r58c

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.struts:struts2-rest-plugin 2.5.13, 2.3.34), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
Confirmed: listed in the CISA Known Exploited Vulnerabilities catalog.
CVSS
8.1 · CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H/E:H
EPSS
  • CVE-2017-9805: 99.40% estimated exploitation activity in the next 30 days; percentile 99.94 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

The REST Plugin in Apache Struts 2.1.1 through 2.3.x before 2.3.34 and 2.5.x before 2.5.13 uses an XStreamHandler with an instance of XStream for deserialization without any type filtering, which can lead to Remote Code Execution when deserializing XML payloads.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-gg9m-fj3v-r58c

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2017-9805

Advisory: REST Plugin in Apache Struts uses an XStreamHandler with an instance of XStream for deserialization without any type filtering
IDs: CVE-2017-9805, GHSA-gg9m-fj3v-r58c
Record: https://patchnext.com/advisories/cve-2017-9805 (revision 1, source checked 26 Oct 2026, 16:40 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.1)
Exploitation: confirmed: listed in the CISA Known Exploited Vulnerabilities catalog.
Vendor response: Vendor fix available; fixed versions by package: org.apache.struts:struts2-rest-plugin 2.5.13, 2.3.34. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.apache.struts:struts2-rest-plugin: affected >= 2.5.0, < 2.5.13; >= 2.1.1, < 2.3.34; fixed in 2.3.34, 2.5.13

## Suggested inspection (read-only)
- Maven org.apache.struts:struts2-rest-plugin: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.apache.struts:struts2-rest-plugin.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-gg9m-fj3v-r58c (GitHub-reviewed advisory GHSA-gg9m-fj3v-r58c lists affected ranges: Maven org.apache.struts:struts2-rest-plugin >=2.5.0 =2.1.1 <2.3.34)
- Verified: https://www.cisa.gov/known-exploited-vulnerabilities-catalog (CISA added CVE-2017-9805 to the Known Exploited Vulnerabilities catalog on 2021-11-03.)

Commands are suggestions: review each one before running it.

Loading voting…