The REST Plugin in Apache Struts is using an outdated XStream library
CVE-2017-9793GHSA-vwxj-6m5m-rrvh
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.struts:struts2-rest-plugin 2.5.13, 2.3.34), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.apache.struts:struts2-rest-plugin
- Affected
- >= 2.5.0, <= 2.5.12< 2.3.34
- Fixed in
- 2.3.34, 2.5.13
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-vwxj-6m5m-rrvh lists affected ranges: Maven org.apache.struts:struts2-rest-plugin >=2.5.0 =0 <2.3.34
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2017-9793: 8.79% estimated exploitation activity in the next 30 days; percentile 95.18 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The REST Plugin in Apache Struts 2.3.7 through 2.3.33 and 2.5 through 2.5.12 is using an outdated XStream library which is vulnerable and allow perform a DoS attack using malicious request with specially crafted XML payload.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-vwxj-6m5m-rrvh
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2017-9793 Advisory: The REST Plugin in Apache Struts is using an outdated XStream library IDs: CVE-2017-9793, GHSA-vwxj-6m5m-rrvh Record: https://patchnext.com/advisories/cve-2017-9793 (revision 1, source checked 26 Oct 2026, 15:53 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.apache.struts:struts2-rest-plugin 2.5.13, 2.3.34. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.apache.struts:struts2-rest-plugin: affected >= 2.5.0, <= 2.5.12; < 2.3.34; fixed in 2.3.34, 2.5.13 ## Suggested inspection (read-only) - Maven org.apache.struts:struts2-rest-plugin: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.apache.struts:struts2-rest-plugin. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-vwxj-6m5m-rrvh (GitHub-reviewed advisory GHSA-vwxj-6m5m-rrvh lists affected ranges: Maven org.apache.struts:struts2-rest-plugin >=2.5.0 =0 <2.3.34) Commands are suggestions: review each one before running it.
Loading voting…