Apache Struts REST Plugin can potentially allow a DoS attack
CVE-2018-1327GHSA-38cr-2ph5-frr9
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.struts:struts2-rest-plugin 2.5.16), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.apache.struts:struts2-rest-plugin
- Affected
- >= 2.1.1, < 2.5.16
- Fixed in
- 2.5.16
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-38cr-2ph5-frr9 lists affected ranges: Maven org.apache.struts:struts2-rest-plugin >=2.1.1 <2.5.16
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2018-1327: 8.65% estimated exploitation activity in the next 30 days; percentile 95.12 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The Apache Struts REST Plugin is using XStream library which is vulnerable and allow perform a DoS attack when using a malicious request with specially crafted XML payload. Upgrade to the Apache Struts version 2.5.16 and switch to an optional Jackson XML handler as described here http://struts.apache.org/plugins/rest/#custom-contenttypehandlers. Another option is to implement a custom XML handler based on the Jackson XML handler from the Apache Struts 2.5.16.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-38cr-2ph5-frr9
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2018-1327 Advisory: Apache Struts REST Plugin can potentially allow a DoS attack IDs: CVE-2018-1327, GHSA-38cr-2ph5-frr9 Record: https://patchnext.com/advisories/cve-2018-1327 (revision 1, source checked 26 Oct 2026, 16:24 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.apache.struts:struts2-rest-plugin 2.5.16. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.apache.struts:struts2-rest-plugin: affected >= 2.1.1, < 2.5.16; fixed in 2.5.16 ## Suggested inspection (read-only) - Maven org.apache.struts:struts2-rest-plugin: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.apache.struts:struts2-rest-plugin. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-38cr-2ph5-frr9 (GitHub-reviewed advisory GHSA-38cr-2ph5-frr9 lists affected ranges: Maven org.apache.struts:struts2-rest-plugin >=2.1.1 <2.5.16) Commands are suggestions: review each one before running it.
Loading voting…