Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.
Open advisories
9 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.
Impact A flaw has been found in Hazelcast Enterprise Edition and Community Edition, which would allow a low-privileged malicious client to read arbitrary data in memory from any cluster member (including Java heap memory, off-heap data, and JVM process address space). Additionally, such a client may be able to cause one or more cluster members to crash, or in some Enterprise Edition configurations also corrupt memory contents, potentially leading to remote code execution. Both slim and full distributions are affected. Patches Enterprise customers should upgrade to a fixed version of Hazelcast Enterprise Edition: * 5.7.0 * 5.6.1 * 5.5.10 * 5.4.5 Customers with extended support contracts should contact Hazelcast Support for information on patches for older versions. Community Edition users should upgrade to version 5.7.0. Hazelcast also recommends all customers follow the advice in our Security Hardening…
Recommended action: Upgrade to 5.7.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.
Impact Missing authorization checks in the Predicates API may allow a malicious client to execute arbitrary code on a Hazelcast member. Patches Enterprise customers should upgrade to a fixed version of Hazelcast Enterprise Edition: * 5.7.0 * 5.6.1 * 5.5.10 * 5.4.5 Customers with extended support contracts should contact Hazelcast Support for information on patches for older versions. Community Edition users should upgrade to version 5.7.0. Workarounds None - customers are advised to upgrade to a fixed version as soon as possible.
Recommended action: Upgrade to 5.7.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.
Impact In Hazelcast Platform through 5.3.4, a security issue exists within the SQL mapping for the CSV File Source connector. This issue arises from inadequate permission checking, which could enable unauthorized clients to access data from files stored on a member's filesystem. Patches Fix versions: 5.3.5, 5.4.0-BETA-1 Workaround Disabling Hazelcast Jet processing engine in Hazelcast member configuration workarounds the issue. As a result SQL and Jet jobs won't work.
Recommended action: Upgrade to 5.3.5 or 5.2.5 by release line; some affected versions have no fix yet, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.
Impact In Hazelcast Platform, 5.0 through 5.0.4, 5.1 through 5.1.6, and 5.2 through 5.2.3, and Hazelcast IMDG (all versions up to 4.2.z), Executor Services don't check client permissions properly, allowing authenticated users to execute tasks on members without the required permissions granted. Patches Fix versions: 5.3.0, 5.2.4, 5.1.7, 5.0.5 Workarounds Users are only affected when they already use executor services (i.e., an instance exists as a distributed data structure).
Recommended action: Upgrade to 5.2.4, 5.1.7 or 5.0.5 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.
In Hazelcast before 5.3.0, configuration routines don't mask passwords in the member configuration properly. This allows Hazelcast Management Center users to view some of the secrets.
Recommended action: Upgrade to 5.3.0, 5.2.4, 5.1.6 or 5.0.5 by release line; some affected versions have no fix yet, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.
Impact The Connection handler in Hazelcast and Hazelcast Jet allows an unauthenticated, remote attacker to access and manipulate data in the cluster with another authenticated connection's identity. The affected Hazelcast versions are through 3.12.12, 4.0.6, 4.1.9, 4.2.5, 5.0.3, and 5.1.2. The affected Hazelcast Jet versions are through 4.5.3. Patches Hazelcast Jet (and Enterprise) 4.5.4. Hazelcast IMDG (and Enterprise)3.12.13 Hazelcast IMDG (and Enterprise) 4.1.10 Hazelcast IMDG (and Enterprise) 4.2.6 Hazelcast Platform (and Enterprise) 5.1.3 Workarounds There is no known workaround, but setups with TLS and mutual authentication enabled significantly lowers the exploitation risk. References https://support.hazelcast.com/s/article/Security-Advisory-for-CVE-2022-36437
Recommended action: Upgrade to 5.1.3, 5.0.4, 4.2.6 or 2 more by release line; some affected versions have no fix yet, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.
In Hazelcast before 3.11, the cluster join procedure is vulnerable to remote code execution via Java deserialization. If an attacker can reach a listening Hazelcast instance with a crafted JoinRequest, and vulnerable classes exist in the classpath, the attacker can run arbitrary code.
Recommended action: Upgrade to 3.11 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.
The AbstractXmlConfigRootTagRecognizer() function makes use of SAXParser generated from a SAXParserFactory with no FEATURESECUREPROCESSING set, allowing for XXE attacks.
Recommended action: Upgrade to 5.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.
Impact A highly critical 0-day exploit (CVE-2021-44228) is found in Apache log4j 2 library on December 9, 2021. This affects Apache log4j versions from 2.0-beta9 to 2.14.1 (inclusive). This vulnerability allows a remote attacker to execute code on the server if the system logs an attacker-controlled string value with the attacker's JNDI LDAP server lookup. Another vulnerability related to the same library, which was discovered on 12/14/2021 (CVE-2021-45046) and revealed another Remote Code Execution vulnerability, has been investigated by Hazelcast team as well and it is found that it does not affect Hazelcast Products under default configurations. The finding of CVE-2021-45105 on 12/14/2021, which can cause a Denial of Service attack, was investigated by Hazelcast team and it is confirmed that it does not affect Hazelcast Products under default configurations. The finding of CVE-2021-44832 on 12/28/2021, which is a medium vulnerability, is investigated by our security team as well,…
Recommended action: Upgrade to 5.0.2, 4.2.4, 4.1.8 or 4.0.5 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.