Security Advisory for "Log4Shell"
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (com.hazelcast:hazelcast 5.0.2, 4.2.4, 4.1.8, 4.0.5; com.hazelcast.jet:hazelcast-jet 4.5.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven com.hazelcast:hazelcast
- Affected
- >= 5.0, < 5.0.2>= 4.1.1, < 4.1.8>= 4.2, < 4.2.4>= 4.0.0, < 4.0.5
- Fixed in
- 4.1.8, 4.2.4, 5.0.2, 4.0.5
Maven com.hazelcast.jet:hazelcast-jet
- Affected
- >= 4.1, < 4.5.3
- Fixed in
- 4.5.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-v57x-gxfj-484q lists affected ranges: Maven com.hazelcast.jet:hazelcast-jet >=4.1 =5.0 =4.1.1 =4.2 =4.0.0 <4.0.5
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 10.0 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Impact A highly critical 0-day exploit (CVE-2021-44228) is found in Apache log4j 2 library on December 9, 2021. This affects Apache log4j versions from 2.0-beta9 to 2.14.1 (inclusive). This vulnerability allows a remote attacker to execute code on the server if the system logs an attacker-controlled string value with the attacker's JNDI LDAP server lookup. Another vulnerability related to the same library, which was discovered on 12/14/2021 (CVE-2021-45046) and revealed another Remote Code Execution vulnerability, has been investigated by Hazelcast team as well and it is found that it does not affect Hazelcast Products under default configurations. The finding of CVE-2021-45105 on 12/14/2021, which can cause a Denial of Service attack, was investigated by Hazelcast team and it is confirmed that it does not affect Hazelcast Products under default configurations. The finding of CVE-2021-44832 on 12/28/2021, which is a medium vulnerability, is investigated by our security team as well,…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-v57x-gxfj-484q
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-v57x-gxfj-484q Advisory: Security Advisory for "Log4Shell" IDs: GHSA-v57x-gxfj-484q Record: https://patchnext.com/advisories/ghsa-v57x-gxfj-484q (revision 1, source checked 26 Oct 2026, 15:53 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 10.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: com.hazelcast:hazelcast 5.0.2, 4.2.4, 4.1.8, 4.0.5; com.hazelcast.jet:hazelcast-jet 4.5.3. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven com.hazelcast:hazelcast: affected >= 5.0, < 5.0.2; >= 4.1.1, < 4.1.8; >= 4.2, < 4.2.4; >= 4.0.0, < 4.0.5; fixed in 4.1.8, 4.2.4, 5.0.2, 4.0.5 - Maven com.hazelcast.jet:hazelcast-jet: affected >= 4.1, < 4.5.3; fixed in 4.5.3 ## Suggested inspection (read-only) - Maven com.hazelcast:hazelcast: check the installed version with your package manager. - Maven com.hazelcast.jet:hazelcast-jet: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on com.hazelcast:hazelcast, com.hazelcast.jet:hazelcast-jet. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-v57x-gxfj-484q (GitHub-reviewed advisory GHSA-v57x-gxfj-484q lists affected ranges: Maven com.hazelcast.jet:hazelcast-jet >=4.1 =5.0 =4.1.1 =4.2 =4.0.0 <4.0.5) Commands are suggestions: review each one before running it.
Loading voting…