Skip to content

← Public intelligence

Maven package

com.hazelcast.jet:hazelcast-jet

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Critical, CVSS 9.1MavenPublished

    Hazelcast connection caching

    CVE-2022-36437 · GHSA-c5hg-mr8r-f6jp

    Affected
    • Maven com.hazelcast.jet:hazelcast-jet <= 4.5.3
    Fixed in
    4.5.4· Partial vendor fix
    Issue
    Impact The Connection handler in Hazelcast and Hazelcast Jet allows an unauthenticated, remote attacker to access and manipulate data in the cluster with another authenticated connection's identity. The affected Hazelcast versions are through 3.12.12, 4.0.6, 4.1.9, 4.2.5, 5.0.3, and 5.1.2. The affected Hazelcast Jet versions are through 4.5.3. Patches Hazelcast Jet (and Enterprise) 4.5.4. Hazelcast IMDG (and Enterprise)3.12.13 Hazelcast IMDG (and Enterprise) 4.1.10 Hazelcast IMDG (and Enterprise) 4.2.6 Hazelcast Platform (and Enterprise) 5.1.3 Workarounds There is no known workaround, but setups with TLS and mutual authentication enabled significantly lowers the exploitation risk. References https://support.hazelcast.com/s/article/Security-Advisory-for-CVE-2022-36437

    Recommended action: Upgrade to 4.5.4 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Critical, CVSS 10.0MavenPublished

    Security Advisory for "Log4Shell"

    GHSA-v57x-gxfj-484q

    Affected
    • Maven com.hazelcast.jet:hazelcast-jet >= 4.1, < 4.5.3
    Fixed in
    4.5.3· Vendor fix available
    Issue
    Impact A highly critical 0-day exploit (CVE-2021-44228) is found in Apache log4j 2 library on December 9, 2021. This affects Apache log4j versions from 2.0-beta9 to 2.14.1 (inclusive). This vulnerability allows a remote attacker to execute code on the server if the system logs an attacker-controlled string value with the attacker's JNDI LDAP server lookup. Another vulnerability related to the same library, which was discovered on 12/14/2021 (CVE-2021-45046) and revealed another Remote Code Execution vulnerability, has been investigated by Hazelcast team as well and it is found that it does not affect Hazelcast Products under default configurations. The finding of CVE-2021-45105 on 12/14/2021, which can cause a Denial of Service attack, was investigated by Hazelcast team and it is confirmed that it does not affect Hazelcast Products under default configurations. The finding of CVE-2021-44832 on 12/28/2021, which is a medium vulnerability, is investigated by our security team as well,…

    Recommended action: Upgrade to 4.5.3 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →