Hazelcast has an authorization bypass in IMap Predicates API
CVE-2026-107725GHSA-w294-6q5q-53p8
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (com.hazelcast:hazelcast 5.7.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven com.hazelcast:hazelcast
- Affected
- >= 5.6.0, < 5.7.0>= 5.5.0, < 5.7.0< 5.7.0
- Fixed in
- 5.7.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-w294-6q5q-53p8 lists affected ranges: Maven com.hazelcast:hazelcast >=5.6.0 =5.5.0 =0 <5.7.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-107725: 0.39% estimated exploitation activity in the next 30 days; percentile 32.63 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Missing authorization checks in the Predicates API may allow a malicious client to execute arbitrary code on a Hazelcast member.
Patches Enterprise customers should upgrade to a fixed version of Hazelcast Enterprise Edition: * 5.7.0 * 5.6.1 * 5.5.10 * 5.4.5 Customers with extended support contracts should contact Hazelcast Support for information on patches for older versions. Community Edition users should upgrade to version 5.7.0.
Workarounds None - customers are advised to upgrade to a fixed version as soon as possible.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-w294-6q5q-53p8
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-107725 Advisory: Hazelcast has an authorization bypass in IMap Predicates API IDs: CVE-2026-107725, GHSA-w294-6q5q-53p8 Record: https://patchnext.com/advisories/cve-2026-107725 (revision 2, source checked 25 Oct 2026, 04:53 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: com.hazelcast:hazelcast 5.7.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven com.hazelcast:hazelcast: affected >= 5.6.0, < 5.7.0; >= 5.5.0, < 5.7.0; < 5.7.0; fixed in 5.7.0 ## Suggested inspection (read-only) - Maven com.hazelcast:hazelcast: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on com.hazelcast:hazelcast. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-w294-6q5q-53p8 (OSV record GHSA-w294-6q5q-53p8 lists affected ranges: Maven com.hazelcast:hazelcast >=5.6.0 =5.5.0 =0 <5.7.0 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…