Hazelcast allows arbitrary member memory access by low-privileged client
CVE-2026-107726GHSA-6v25-8wq6-xq4j
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (com.hazelcast:hazelcast 5.7.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven com.hazelcast:hazelcast
- Affected
- >= 5.6.0, < 5.7.0>= 5.5.0, < 5.7.0< 5.7.0
- Fixed in
- 5.7.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-6v25-8wq6-xq4j lists affected ranges: Maven com.hazelcast:hazelcast >=5.6.0 =5.5.0 =0 <5.7.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 9.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-107726: 0.38% estimated exploitation activity in the next 30 days; percentile 32.46 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact A flaw has been found in Hazelcast Enterprise Edition and Community Edition, which would allow a low-privileged malicious client to read arbitrary data in memory from any cluster member (including Java heap memory, off-heap data, and JVM process address space). Additionally, such a client may be able to cause one or more cluster members to crash, or in some Enterprise Edition configurations also corrupt memory contents, potentially leading to remote code execution. Both slim and full distributions are affected.
Patches Enterprise customers should upgrade to a fixed version of Hazelcast Enterprise Edition: * 5.7.0 * 5.6.1 * 5.5.10 * 5.4.5 Customers with extended support contracts should contact Hazelcast Support for information on patches for older versions. Community Edition users should upgrade to version 5.7.0. Hazelcast also recommends all customers follow the advice in our Security Hardening…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-6v25-8wq6-xq4j
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-107726 Advisory: Hazelcast allows arbitrary member memory access by low-privileged client IDs: CVE-2026-107726, GHSA-6v25-8wq6-xq4j Record: https://patchnext.com/advisories/cve-2026-107726 (revision 2, source checked 25 Oct 2026, 04:53 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: com.hazelcast:hazelcast 5.7.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven com.hazelcast:hazelcast: affected >= 5.6.0, < 5.7.0; >= 5.5.0, < 5.7.0; < 5.7.0; fixed in 5.7.0 ## Suggested inspection (read-only) - Maven com.hazelcast:hazelcast: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on com.hazelcast:hazelcast. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-6v25-8wq6-xq4j (OSV record GHSA-6v25-8wq6-xq4j lists affected ranges: Maven com.hazelcast:hazelcast >=5.6.0 =5.5.0 =0 <5.7.0 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…